Bug 964357 - cannot change 'behavior' to single-click. (F19 alpha release)
cannot change 'behavior' to single-click. (F19 alpha release)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-file-manager (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 22:49 EDT by fred smith
Modified: 2013-07-10 18:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-file-manager-1.6.1-9.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 21:22:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fred smith 2013-05-17 22:49:44 EDT
Description of problem: 
1. open caja
2. click Edit
3. click preferences
4. click behavior
5. default setting is single-click, but it still requires a double-click.
6. click "double click to open items"
7. click "close" at bottom of window.
8. go back and do steps 2 thru 4 again.
9. note it is still set to single-click, but still requires a double-click.
10. click "double click to open items".
Then caja disappears and all desktop icons flash off and back on.
It STILL requires a double-click.
You can do these steps til the cows come home and it always crashes caja
and never activates single-click.


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1.see above.
2.
3.
  
Actual results:


Expected results:
1. doesn't crash caja
2. allows single-click behavior.

Additional info:
Comment 2 fred smith 2013-06-29 12:05:33 EDT
is there going to be a fixed RPM one of these days, please?
Comment 3 Wolfgang Ulbrich 2013-06-29 12:22:48 EDT
The trick is to change to double click and back to single click in preferences.
Does this works for you?
Is the setting is alive if you restart the session?
The fix is in upstream and will be available with mate-file-manager-1.6.2,
if the workaround is working for you i won't patch caja.
Comment 4 fred smith 2013-06-29 12:31:04 EDT
Wolfgang: thanks for the hint. I thought I had tried all the possible incantations, and that one seems so simple I'd think I would have tried it, but apparently I hadn't because having just done that I now have the behavior I want.

So, don't feel pressured to issue a fix just for me, but I suspect I'm not the only one who'd like it fixed eventually.
Comment 5 Fedora Update System 2013-06-30 07:48:25 EDT
mate-file-manager-1.6.1-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-file-manager-1.6.1-8.fc19
Comment 6 Fedora Update System 2013-06-30 20:47:05 EDT
mate-file-manager-1.6.1-9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-file-manager-1.6.1-9.fc19
Comment 7 Fedora Update System 2013-07-01 20:27:11 EDT
Package mate-file-manager-1.6.1-9.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-file-manager-1.6.1-9.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12106/mate-file-manager-1.6.1-9.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-07-09 21:22:48 EDT
mate-file-manager-1.6.1-9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 fred smith 2013-07-10 18:08:56 EDT
just installed that update, and it now appears to be working here. Thanks all who were involved in fixing it!

Note You need to log in before you can comment on or make changes to this bug.