Bug 964376 - SELinux is preventing /home/mikhail/.local/share/Steam/SteamApps/common/Team Fortress 2/hl2_linux from using the 'execheap' accesses on a process.
SELinux is preventing /home/mikhail/.local/share/Steam/SteamApps/common/Team ...
Status: CLOSED DUPLICATE of bug 904691
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c210ed67bf30efcdba620f43719...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 02:47 EDT by Mikhail
Modified: 2013-05-20 05:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 05:35:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2013-05-18 02:47:12 EDT
Description of problem:
SELinux is preventing /home/mikhail/.local/share/Steam/SteamApps/common/Team Fortress 2/hl2_linux from using the 'execheap' accesses on a process.

*****  Plugin allow_execheap (53.1 confidence) suggests  *********************

If you do not think /home/mikhail/.local/share/Steam/SteamApps/common/Team Fortress 2/hl2_linux should need to map heap memory that is both writable and executable.
Then you need to report a bug. This is a potentially dangerous access.
Do
contact your security administrator and report this issue.

*****  Plugin catchall_boolean (42.6 confidence) suggests  *******************

If you want to allow unconfined executables to make their heap memory executable.  Doing this is a really bad idea. Probably indicates a badly coded executable, but could indicate an attack. This executable should be reported in bugzilla
Then you must tell SELinux about this by enabling the 'selinuxuser_execheap' boolean.
You can read 'unconfined_selinux' man page for more details.
Do
setsebool -P selinuxuser_execheap 1

*****  Plugin catchall (5.76 confidence) suggests  ***************************

If you believe that hl2_linux should be allowed execheap access on processes labeled unconfined_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep hl2_linux /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ process ]
Source                        hl2_linux
Source Path                   /home/mikhail/.local/share/Steam/SteamApps/common/
                              Team Fortress 2/hl2_linux
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-301.fc19.i686.PAE #1 SMP Mon
                              May 13 12:47:57 UTC 2013 i686 i686
Alert Count                   12
First Seen                    2013-05-10 18:30:01 YEKT
Last Seen                     2013-05-18 03:11:57 YEKT
Local ID                      e9ed19aa-832b-4072-b040-1277796cd398

Raw Audit Messages
type=AVC msg=audit(1368825117.926:533): avc:  denied  { execheap } for  pid=10984 comm="hl2_linux" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1368825117.926:533): arch=i386 syscall=mprotect success=no exit=EACCES a0=1b610000 a1=c000 a2=7 a3=bfbadc1c items=0 ppid=10981 pid=10984 auid=1000 uid=1000 gid=0 euid=1000 suid=1000 fsuid=1000 egid=0 sgid=0 fsgid=0 ses=1 tty=pts3 comm=hl2_linux exe=2F686F6D652F6D696B6861696C2F2E6C6F63616C2F73686172652F537465616D2F537465616D417070732F636F6D6D6F6E2F48616C662D4C69666520322F686C325F6C696E7578 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: hl2_linux,unconfined_t,unconfined_t,process,execheap

audit2allow

#============= unconfined_t ==============

#!!!! This avc can be allowed using the boolean 'selinuxuser_execheap'
allow unconfined_t self:process execheap;

audit2allow -RYou must regenerate interface info by running /usr/bin/sepolgen-ifgen


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.2-301.fc19.i686.PAE
type:           libreport

Potential duplicate: bug 904691
Comment 1 Miroslav Grepl 2013-05-20 05:35:16 EDT

*** This bug has been marked as a duplicate of bug 904691 ***

Note You need to log in before you can comment on or make changes to this bug.