This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 9644 - rpm find_requires misidentifies some executable files
rpm find_requires misidentifies some executable files
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-21 10:47 EST by Nigel Metheringham
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-21 11:46:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Metheringham 2000-02-21 10:47:00 EST
Latest xemacs build gave:-
  Finding  Requires: (using /usr/lib/rpm/find-requires)...
  objdump:
/var/tmp/xemacs-root/usr/lib/xemacs/xemacs-packages/lisp/sh-script/executable.el:
File format not recognized

This is due to in find_requires:-
  exelist=`echo $filelist | xargs -r file | fgrep executable | cut -d: -f1
`

which misidentifies the .el file as executable because its name contains
"executable".

if the grep is changed as per the script list one, so its:-
  exelist=`echo $filelist | xargs -r file | egrep ":.* executable" | cut
-d: -f1 `

then that cuts out all the false positives - I can see no false negatives
that this will add.
Comment 1 Jeff Johnson 2000-02-21 11:46:59 EST
Thanks for the patch. A change similar to this has already been checked
in and should be in (at least) rpm-3.0.4-0.44.

Note You need to log in before you can comment on or make changes to this bug.