Bug 964414 - eclipse: Felix Gogo shell is gone
eclipse: Felix Gogo shell is gone
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 06:24 EDT by Mikolaj Izdebski
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 03:01:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-05-18 06:24:51 EDT
Description of problem:
In Fedora 18 Eclipse had CLI option -console which opened Apache Felix Gogo shell in terminal. The shell was useful to debug OSGi problems.

In Fedora 19 the Felix Gogo shell doesn't appear after passing -console option to eclipse. I don't know if this change is intentional or not, but the console was important feature for me.

Version-Release number of selected component (if applicable):
eclipse-platform-4.3.0-0.48.git4bccf2.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. Run eclipse -console
  
Actual results:
No Apache Felix Gogo appears

Expected results:
Apache Felix Gogo console shows up in terminal
Comment 1 Alexander Kurtakov 2013-05-20 02:16:29 EDT
Hmm, it starts fine for me. Can you try running with -clean to see whether there any resolving issues? Or as a last resort mv ~/.eclipse ~/.eclipse.old to see whether it helps?
Comment 2 Mikolaj Izdebski 2013-07-20 17:35:40 EDT
The shell is back with current Fedora 19 + updates-testing.
Comment 3 Krzysztof Daniel 2013-07-22 03:01:05 EDT
Those bugs are caused by deps being out of sync. Rebuilds usually help. Closing as worksfor me per comment 2.

Note You need to log in before you can comment on or make changes to this bug.