Bug 964415 - eclipse-fedorapackager: Only documentation plugin loads
eclipse-fedorapackager: Only documentation plugin loads
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-fedorapackager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 06:41 EDT by Mikolaj Izdebski
Modified: 2014-01-12 19:27 EST (History)
7 users (show)

See Also:
Fixed In Version: eclipse-fedorapackager-0.4.1-7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 01:53:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eclipse -consolelog -debug -clean (6.81 KB, text/x-log)
2013-05-18 06:42 EDT, Mikolaj Izdebski
no flags Details
installed plugins with "fedora" in name (37.36 KB, image/png)
2013-05-18 06:43 EDT, Mikolaj Izdebski
no flags Details
eclipse -consolelog -debug -clean (7.08 KB, text/x-log)
2013-05-18 06:46 EDT, Mikolaj Izdebski
no flags Details

  None (edit)
Description Mikolaj Izdebski 2013-05-18 06:41:12 EDT
Description of problem:
After installing eclipse-fedorapackager only documentation plugin is loaded into Eclipse. All functionality of eclipse-fedorapackager is missing, as if it wasn't installed.

Version-Release number of selected component (if applicable):
eclipse-fedorapackager-0.4.1-6.fc19.noarch
eclipse-platform-4.3.0-0.48.git4bccf2.fc19.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. yum install eclipse-fedorapackager-0.4.1-6.fc19.noarch
2. try to open Fedora packaging perspective
3. check loaded bundles
  
Actual results:
There is no Fedora packaging perspective and other options like importing of Fedora pakages etc. are missing. Fedora packager bundles don't show in installation details (except documentation plugin).

Expected results:
Fedora packaging perspective is present.

Additional info:
Attached.
Comment 1 Mikolaj Izdebski 2013-05-18 06:42:20 EDT
Created attachment 749612 [details]
eclipse -consolelog -debug -clean
Comment 2 Mikolaj Izdebski 2013-05-18 06:43:15 EDT
Created attachment 749613 [details]
installed plugins with "fedora" in name
Comment 3 Mikolaj Izdebski 2013-05-18 06:46:29 EDT
Created attachment 749614 [details]
eclipse -consolelog -debug -clean

Ignore the previous log, I have picked wrong one by mistake.
Comment 4 Sami Wagiaalla 2013-06-05 10:39:02 EDT
Thanks for the bug report Mikolaj.
This is due to API change and consequently ABI incompatibility. It should be fixed by the next build
Comment 5 Alexander Kurtakov 2013-06-05 11:50:44 EDT
Mikolaj, 
Just to doublecheck, can you sudo touch /usr/lib[64]/eclipse/configuration/config.ini and restart eclipse and let me know whether it changes anything?
Comment 6 Neil Brian Guzman 2013-07-05 21:58:18 EDT
Akurtakov,
I tried touching the config.ini, but still only docs is installed.

The packager/plugins folder seems to contain everything, but I still don't see it in eclipse.

Using:
Kepler & F19
Comment 7 Krzysztof Daniel 2013-07-08 12:45:10 EDT
If only one bundle is loaded, then reconciler works, but the problem lies within dependencies.

If Eclipse is working fine and other products are installed properly even after touching config.ini, then it is most probably broken symlink somewhere. 

You may want to get a log with a very detailed resolution tracing http://aniszczyk.org/2011/04/04/debugging-eclipse-p2-dropins/.

It should tell what is missing (I expect broken symlink).
Comment 8 Fedora Update System 2013-07-12 12:54:47 EDT
eclipse-fedorapackager-0.4.1-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/eclipse-fedorapackager-0.4.1-7.fc19
Comment 9 Fedora Update System 2013-07-13 23:26:02 EDT
Package eclipse-fedorapackager-0.4.1-7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-fedorapackager-0.4.1-7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12947/eclipse-fedorapackager-0.4.1-7.fc19
then log in and leave karma (feedback).
Comment 10 Mikolaj Izdebski 2013-07-16 16:06:58 EDT
I confirm that adding symlink to jakarta-commons-httpclient fixed this bug -- eclipse-fedorapackager works for me now.  Thank you.
Comment 11 Fedora Update System 2013-07-18 01:53:50 EDT
eclipse-fedorapackager-0.4.1-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.