Bug 964586 - Anaconda does not isntall ntfs tools to allow OS-Prober to find windows partition and therefore creates no grub.cfg entry
Anaconda does not isntall ntfs tools to allow OS-Prober to find windows parti...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 973424 (view as bug list)
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-05-18 23:39 EDT by Robert Lightfoot
Modified: 2013-08-08 11:28 EDT (History)
14 users (show)

See Also:
Fixed In Version: pykickstart-1.99.32-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 11:11:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Lightfoot 2013-05-18 23:39:50 EDT
Description of problem:
OS-Prober does not find windows partition and therefore creates no grub.cfg entry

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.  Install Fedora from DVD
2. 
3.
  
Actual results:
Grub has only fedora entry

Expected results:
Entries for Fedora and Windows

Additional info:
Fails for XP and Win8
Comment 1 Robert Lightfoot 2013-05-19 08:02:15 EDT
further investigation finds this problem is in the package manifesting. IF the ntfsprogs and utils are not isntalled then os-prober cannot read the Windows partition and create boot entry.  Current minimal package manifest does not install ntfs.
Comment 2 Brian Lane 2013-05-23 16:21:31 EDT
I think os-prober should handle requiring what it needs in order to function.
Comment 3 Hedayat Vatankhah 2013-05-25 04:53:00 EDT
os-prober doesn't "need" ntfs support. It'll use it if it is available. The same thing goes for LVM etc... . Once, os-prober has many dependencies like lvm, but it turned out that it is problematic.

For example, people doesn't need LVM but they want os-prober to be present. And if they don't have LVM, os-prober runs without any problems. 

Therefore, os-prober doesn't need ntfs support and it functions without it (it just skips ntfs partitions). It is up to Anaconda to decide how rich its generated grub menu should be. As another example, Anaconda doesn't generate menu entries for OSes installed on LVM partition (a common Fedora case!) since it doesn't activate them when running os-prober (Bug #825236) which is something os-prober can't do (explained there). os-prober runs in a context which is provided by the environment.

Anyway, I suggest anaconda requires ntfs support to support HDD installation support from NTFS partitions (bug #748780).

I really appreciate if you add such dependencies to Anaconda itself rather than os-prober. If there were anything like "suggested dependencies" or "optional dependencies" I'd be happy to add things like ntfs and LVM support there, but not as a hard dependency.
Comment 4 Adam Williamson 2013-05-29 13:48:43 EDT
Discussed at 2013-05-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-29/f19final-blocker-review-1.2013-05-29-16.02.log.txt . Accepted as a blocker per criterion "The installer must be able to install into free space alongside an existing clean single-partition Windows installation and either install a bootloader which can boot into the Windows installation, or leave the Windows bootloader untouched and working" .

We don't want to wade into the debate about how this should be fixed, but we thought it was clear that it does need to be fixed. Dual boot functionality is a pretty key feature for 'Linux' in general: people expect it to work, and they get angry when it doesn't. 'Windows just doesn't care about other OSes so when you install it it blocks access to them; Linux does it right!' has been a Linux boast since time immemorial...

So, the +1 blocker here means: when installing Fedora alongside Windows in a typical configuration (which obviously includes 'Windows on NTFS'), dual boot needs to be set up. We don't mind how that's achieved.
Comment 5 Kamil Páral 2013-05-30 10:12:49 EDT
I tried Windows 8 32bit and Fedora 18 minimal install - the system detects Windows just fine, displays a menu item in GRUB, and ntfs-3g and ntfsprogs packages are installed.
Comment 6 Kamil Páral 2013-05-30 10:28:03 EDT
Then I installed Fedora 19 minimal install and Windows are not detected, and no ntfs packages are installed. So this is definitely a regression.
Comment 7 Fedora Update System 2013-06-14 12:45:08 EDT
pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.6-1.fc19
Comment 8 Fedora Update System 2013-06-15 13:06:51 EDT
Package anaconda-19.30.7-1.fc19, pykickstart-1.99.32-1.fc19, python-blivet-0.16-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30.7-1.fc19 pykickstart-1.99.32-1.fc19 python-blivet-0.16-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10913/pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.7-1.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-06-18 02:16:13 EDT
pykickstart-1.99.32-1.fc19, python-blivet-0.16-1.fc19, anaconda-19.30.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Kamil Páral 2013-06-18 06:30:27 EDT
Setting back to ON_QA, since this is a blocker and we need to verify it.
Comment 11 Jan Sedlák 2013-06-19 04:43:28 EDT
Confirming that minimal install works in dualboot with Windows 8 in F19 TC5.
Comment 12 Adam Williamson 2013-06-19 11:11:39 EDT
Awesome, then we can close this. Thanks.
Comment 13 David Shea 2013-08-08 11:28:57 EDT
*** Bug 973424 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.