Bug 964656 - SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'append' accesses on the unix_stream_socket unix_stream_socket.
SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'append' ...
Status: CLOSED DUPLICATE of bug 964651
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c9365d252fdb96bb5bebcd853b0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 08:11 EDT by vinesh teotia
Modified: 2013-05-22 14:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 14:46:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vinesh teotia 2013-05-19 08:11:27 EDT
Description of problem:
SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'append' accesses on the unix_stream_socket unix_stream_socket.

*****  Plugin leaks (86.2 confidence) suggests  ******************************

If you want to ignore nacl_helper_bootstrap trying to append access the unix_stream_socket unix_stream_socket, because you believe it should not need this access.
Then you should report this as a bug.  
You can generate a local policy module to dontaudit this access.
Do
# grep /opt/google/chrome/nacl_helper_bootstrap /var/log/audit/audit.log | audit2allow -D -M mypol
# semodule -i mypol.pp

*****  Plugin catchall (14.7 confidence) suggests  ***************************

If you believe that nacl_helper_bootstrap should be allowed append access on the unix_stream_socket unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep nacl_helper_boo /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_nacl_t:s0
                              -s0:c0.c1023
Target Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Objects                unix_stream_socket [ unix_stream_socket ]
Source                        nacl_helper_boo
Source Path                   /opt/google/chrome/nacl_helper_bootstrap
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           google-chrome-stable-26.0.1410.63-192696.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-301.fc19.x86_64 #1 SMP Mon
                              May 13 12:36:24 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-11 05:30:35 IST
Last Seen                     2013-05-19 09:39:23 IST
Local ID                      e251c0d0-dc59-4797-8470-917829dd5d23

Raw Audit Messages
type=AVC msg=audit(1368936563.424:559): avc:  denied  { append } for  pid=6740 comm="nacl_helper_boo" path="socket:[78616]" dev="sockfs" ino=78616 scontext=unconfined_u:unconfined_r:chrome_sandbox_nacl_t:s0-s0:c0.c1023 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=SYSCALL msg=audit(1368936563.424:559): arch=x86_64 syscall=execve success=yes exit=0 a0=7f17b890d428 a1=7f17b88fc510 a2=7fff12921200 a3=7f17b2940080 items=0 ppid=1 pid=6740 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=3 tty=(none) comm=nacl_helper_boo exe=/opt/google/chrome/nacl_helper_bootstrap subj=unconfined_u:unconfined_r:chrome_sandbox_nacl_t:s0-s0:c0.c1023 key=(null)

Hash: nacl_helper_boo,chrome_sandbox_nacl_t,xdm_t,unix_stream_socket,append

audit2allow

#============= chrome_sandbox_nacl_t ==============
allow chrome_sandbox_nacl_t xdm_t:unix_stream_socket append;

audit2allow -RYou must regenerate interface info by running /usr/bin/sepolgen-ifgen


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.2-301.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-05-22 14:46:33 EDT

*** This bug has been marked as a duplicate of bug 964651 ***

Note You need to log in before you can comment on or make changes to this bug.