Bug 964669 - SELinux is preventing /usr/bin/gnome-keyring-daemon from 'read' accesses on the chr_file random.
SELinux is preventing /usr/bin/gnome-keyring-daemon from 'read' accesses on t...
Status: CLOSED DUPLICATE of bug 964292
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a2ee8f9cef466e2ade0b72ec8b6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 08:21 EDT by vinesh teotia
Modified: 2013-05-20 03:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 03:52:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vinesh teotia 2013-05-19 08:21:32 EDT
Description of problem:
SELinux is preventing /usr/bin/gnome-keyring-daemon from 'read' accesses on the chr_file random.

*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************

If you want to allow users to resolve user passwd entries directly from ldap rather then using a sssd server
Then you must tell SELinux about this by enabling the 'authlogin_nsswitch_use_ldap' boolean.
You can read 'None' man page for more details.
Do
setsebool -P authlogin_nsswitch_use_ldap 1

*****  Plugin catchall (11.6 confidence) suggests  ***************************

If you believe that gnome-keyring-daemon should be allowed read access on the random chr_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gnome-keyring-d /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:random_device_t:s0
Target Objects                random [ chr_file ]
Source                        gnome-keyring-d
Source Path                   /usr/bin/gnome-keyring-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-keyring-3.8.2-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-42.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.1-301.fc19.x86_64 #1 SMP Wed
                              May 8 18:02:34 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-13 16:51:09 IST
Last Seen                     2013-05-13 16:51:09 IST
Local ID                      439dcb12-21a7-487b-8f36-ce0cda7ea889

Raw Audit Messages
type=AVC msg=audit(1368444069.135:461): avc:  denied  { read } for  pid=2700 comm="gnome-keyring-d" name="random" dev="devtmpfs" ino=7174 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:random_device_t:s0 tclass=chr_file


type=SYSCALL msg=audit(1368444069.135:461): arch=x86_64 syscall=access success=yes exit=0 a0=3561268ba4 a1=4 a2=0 a3=0 items=0 ppid=2699 pid=2700 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 ses=4294967295 tty=(none) comm=gnome-keyring-d exe=/usr/bin/gnome-keyring-daemon subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: gnome-keyring-d,xdm_dbusd_t,random_device_t,chr_file,read

audit2allow

#============= xdm_dbusd_t ==============

#!!!! This avc can be allowed using the boolean 'authlogin_nsswitch_use_ldap'
allow xdm_dbusd_t random_device_t:chr_file read;

audit2allow -RYou must regenerate interface info by running /usr/bin/sepolgen-ifgen


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.2-301.fc19.x86_64
type:           libreport

Potential duplicate: bug 742796
Comment 1 Miroslav Grepl 2013-05-20 03:52:05 EDT

*** This bug has been marked as a duplicate of bug 964292 ***

Note You need to log in before you can comment on or make changes to this bug.