Bug 964766 - Gedit Edit - Preferences Menu Item missing
Gedit Edit - Preferences Menu Item missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 14:12 EDT by D. Charles Pyle
Modified: 2013-10-20 18:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 20:40:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. Charles Pyle 2013-05-19 14:12:46 EDT
Description of problem:

After updates yesterday, the Edit Preferences Menu item went missing.

Version-Release number of selected component (if applicable):
gedit-3.8.2-1.fc19.x86_64

How reproducible:
100% and so far unreversible.

Steps to Reproduce:
1.  Run gedit.
2.  Click Edit menu
3.  No Preferences Menu item.
  
Actual results:
Missing Edit --> Preferences menu item

Expected results:
See preferences menu item to set preferences

Additional info:

I have tried reinstalling, downgrading to previous versions, and removing and reinstalling gedit packages, plugins, and so forth, as well as recompiling schemas, with zero results.  No matter what I have tried the preferences menu item will not come back.  I cannot enable and/or disable plugins, and cannot change preferences.
Comment 1 D. Charles Pyle 2013-05-19 14:43:44 EDT
Just checked to see whether a preferences file is the problem. This problem affects all users on my machine, including root.
Comment 2 Erik Bartoš 2013-06-06 05:41:14 EDT
It has moved to the gedit icon on the top bar, next to Activities. There is a lot of stuff as: Preferences, Help, About...
Comment 3 D. Charles Pyle 2013-06-06 13:58:00 EDT
At the time I filed this report, it wasn't even present there.  I looked there first because I had seen menu items from Software Installer go there previously.  But, in the case of gedit, the preferences menu just completely disappeared for about a week, and then came back.  It is, as you say, there in the panel now, and has been since a round of updates gave it back.  I would say the problem pretty much is resolved.
Comment 4 Rodd Clarkson 2013-06-09 06:30:09 EDT
I'm having the same problem too.

I guess the solution offered in Comment 3 is useful, but some education of long time users might be useful.

I also question the wisdom of splitting menus between menus in the application windows and the whatever it's called bar at the top.  That seems a little like a dogs breakfast.
Comment 5 Matthias Clasen 2013-06-14 20:40:59 EDT
As the previous comments show, it didn't go missing. It was just relocated.
Comment 6 D. Charles Pyle 2013-06-14 21:20:21 EDT
No, it did go missing. It was nowhere. I know because that was the first place I I looked for it when I saw it gone from the original place.  It was neither in the former place nor in the application menu next to the activities menu.  No big deal, though, because the problem was fixed after some updates to Gnome Shell, whatever the cause.  But, it looks like I am going to have to start submitting screen shots with some bug reports of this kind.  Next time... :-)
Comment 7 itsjustarumour 2013-10-20 18:16:24 EDT
@Matthias Clasen - yes it has been relocated for a normal user, but unfortunately the preferences are now unavailable for a root user using this method.

Note You need to log in before you can comment on or make changes to this bug.