Bug 9648 - Apache with PHP and DB or DBM Auth.
Apache with PHP and DB or DBM Auth.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-21 12:02 EST by wjwarner
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-29 15:31:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wjwarner 2000-02-21 12:02:31 EST
Background:
I have a working website running an old
Apache-1.1-plus-PHP/FI-2.0b4 that uses
an NDBM file (has .dir  and .pag)
for htaccess control via the Apache AuthDBMUserFile directive.

The NDBM file is updated on-line by .phtml
(PHP/FI) scripts to add new users.
This works fine (on RH  6.1) now but I want
to upgrade the server and stay as stock as possible.

Problem:
Apache-1.3.x in the RH 6.1 Distribution has
DB but not DBM Authentication built in while
the included PHP2 and PHP3 Modules are configured
to access only GDBM files.  This seems inconsistent
(DB in one part and GDBM in the other part of the same
Apache rpm)

I'm in the process of using the source rpms for
Apache and PHP2 and PHP3 to build something that
works for me.  I think the issues include:

- data file compatibility/ conversion
  about 12,000 user entries in NDBM file
  (dbmmanage view and import seem to work ok)

- concurrent updates possible so reliable locking
  in the PHP module needed

Can you give a novice some direction here so I can stay as compatible
as possible with future (stock) upgrades.  The choices for me
seem to be:
-Both Auth and php use DB (SleepyCat rel-1.x > rel 2.x ?)
-Both use NDBM linked to DB (as per RH Distribution)
-Both use NDBM linked to GDBM
-Both use GDBM
Comment 1 Nalin Dahyabhai 2000-02-29 15:31:59 EST
The apache package's history indicates instabilities when linked with ndbm or
GDBM, so I'd recommend using DB if possible.  That PHP is currently built
without db support is an oversight, and will be corrected in php-3.0.15, which
should be available starting in the next Raw Hide snapshot.  PHP/FI does not
support DB 2.x at all.

Note You need to log in before you can comment on or make changes to this bug.