Bug 964945 - awesome: Text editor should default to vi, not nano
awesome: Text editor should default to vi, not nano
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: awesome (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 02:24 EDT by Mikolaj Izdebski
Modified: 2013-06-08 23:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: awesome-3.5.1-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-08 23:33:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (2.64 KB, patch)
2013-05-20 02:25 EDT, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description Mikolaj Izdebski 2013-05-20 02:24:22 EDT
Description of problem:
With default installation when trying to edit config file (Mod4-W,
awesome => edit config) xterm window pops up for a short moment and
disappears.  It turns out that default awesome config file specifies
nano as default text editor.

In Fedora the default text editor is vi, nano is not available in
default installation and awesome doesn't depend on it.  In my opinion
awesome should either set default editor to vi (preferably) or require
nano.

Version-Release number of selected component (if applicable):
3.4.15-1

How reproducible:
always

Steps to Reproduce:
1. using default configuration, try to edit config file (Mod4-W,
awesome => edit config)

Actual results:
editor doesn't show up

Expected results:
some editor shows up allowing further customizations (like changing the editor itself)
Comment 1 Mikolaj Izdebski 2013-05-20 02:25:04 EDT
Created attachment 750429 [details]
Proposed patch
Comment 2 Thomas Moschny 2013-05-25 08:47:05 EDT
Thanks for the patch! Fixed in awesome-3.5.1-5.fc20.

Also commited on F19 branch. Probably not worth an update.
Comment 3 Fedora Update System 2013-05-28 15:08:17 EDT
awesome-3.5.1-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/awesome-3.5.1-4.fc19
Comment 4 Fedora Update System 2013-05-29 13:44:34 EDT
Package awesome-3.5.1-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing awesome-3.5.1-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9553/awesome-3.5.1-4.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-08 23:33:57 EDT
awesome-3.5.1-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.