Bug 964949 - Subtab goes missing
Subtab goes missing
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.2
Unspecified Linux
unspecified Severity medium
: ---
: 3.3
Assigned To: Alexander Wels
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 03:48 EDT by Noam Slomianko
Modified: 2013-10-24 20:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 03:36:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List item selected and the sub tab isn't shown (96.92 KB, image/png)
2013-05-20 03:48 EDT, Noam Slomianko
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 14957 None None None Never

  None (edit)
Description Noam Slomianko 2013-05-20 03:48:26 EDT
Created attachment 750438 [details]
List item selected and the sub tab isn't shown

Description of problem:
Sub tab isn't shown in a certain flow.
The example below is just for clarity, it happens with any tab.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Click on DC tab
2. Click on a list item (sub tab appear) 
3. Click on Cluster tab
4. Click on DC tab
5. Click on the same list item (sub tab does not appear)

Actual results:
Sub tab isn't shown

Expected results:
Sub tab should appear

Additional info:
Reported by lof yer
Comment 1 vszocs 2013-05-21 09:04:39 EDT
This is a regression caused by [http://gerrit.ovirt.org/#/c/14820/] -> AbstractSubTabPanelPresenter.onReveal() isn't called while revealing different sub-tabs for the same main-tab [based on main-tab selection].

I'll go ahead and make a fix patch.
Comment 2 Itamar Heim 2013-08-21 12:43:12 EDT
as RC is built, moving to ON_QA (hopefully did not catch incorrect bugs when doing this)
Comment 3 Itamar Heim 2013-09-23 03:36:14 EDT
closing as this should be in 3.3 (doing so in bulk, so may be incorrect)

Note You need to log in before you can comment on or make changes to this bug.