Bug 964977 - gdm-control and gnome-panel-control require former gnome-panel package
gdm-control and gnome-panel-control require former gnome-panel package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openbox (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 04:47 EDT by Jens Petersen
Modified: 2014-07-07 10:41 EDT (History)
7 users (show)

See Also:
Fixed In Version: openbox-3.5.2-5.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-07 09:12:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2013-05-20 04:47:37 EDT
Description of problem:
From the F-19 Branched report:

[openbox]
        gdm-control-3.5.0-11.20121001git782b28.fc19.x86_64 requires gnome-panel
        gnome-panel-control-3.5.0-11.20121001git782b28.fc19.x86_64 requires gnome-panel

but gnome-panel is no longer available in F19 unfortunately.

Perhaps openbox could be patch to work instead with mate-panel?
Comment 1 Miroslav Lichvar 2013-05-20 05:19:28 EDT
Hm, did gnome break openbox again?

I personally have no interest in keeping the gnome support as it seems to break so often and I'm not a gnome/mate user, but if anyone would like to update it, please feel free to do it or send me the patches.
Comment 2 Christoph Wickert 2013-05-20 05:51:13 EDT
(In reply to Miroslav Lichvar from comment #1)
> Hm, did gnome break openbox again?

No, gnome-panel was removed from GNOME and our distribution.
 
> I personally have no interest in keeping the gnome support as it seems to
> break so often and I'm not a gnome/mate user, but if anyone would like to
> update it, please feel free to do it or send me the patches.

I'm not a GNOME/MATE user either, but I'll fix it.
Comment 3 Ian Neal 2013-07-14 12:03:08 EDT
Is there a temporary workaround for this?
Comment 4 Jens Petersen 2013-07-15 21:25:35 EDT
(In reply to Ian Neal from comment #3)
> Is there a temporary workaround for this?

How is it affecting you?
Comment 5 Jens Petersen 2013-07-15 21:26:23 EDT
Well workaround is to remove gdm-control and gnome-panel-control... :)
Comment 6 Ian Neal 2013-07-16 14:47:03 EDT
(In reply to Jens Petersen from comment #4)
> (In reply to Ian Neal from comment #3)
> > Is there a temporary workaround for this?
> 
> How is it affecting you?

Well, I've never used gnome-panel-control but I have used gdm-control occasionally in the past (not for a while though).
Comment 7 Sergio Monteiro Basto 2013-08-31 11:40:31 EDT
I think I hit this bug, with : 

yum install gnome-panel\*
Error: Package: gnome-panel-control-3.5.2-2.fc19.x86_64 (updates)
           Requires: gnome-panel

gnome-panel-control requires a package that not exist: gnome-panel .
Comment 8 Dan Mashal 2013-12-09 04:00:59 EST
Possibly a rebuild with a minor patch should fix this permanently. If Christoph doesn't fix it I will try to.
Comment 9 Christoph Wickert 2013-12-10 11:20:28 EST
The reason this takes so long is that I don't know what to do. 

gdm-control requiring gnome-panel is simply a copy & paste bug, should be gdm of course. Fixed in 3.5.2-3.fc21 which is just building for rawhide.

gnome-panel-control is harder. Dan, do you know it works with mate-panel or if we can make it work? The code looks straight forward, but I'm note sure if mate-panel supports it (of if gnome-panel actually worked at the point they forked).

Given that it works, we should probably rename it to mate-panel-control. What are we going to do about the openbox-gnome package then? Having it depend on mate-panel(-control) sounds wrong. Should we rename it, too?
Comment 10 Dan Mashal 2013-12-10 12:02:42 EST
I spent time on this last night, basically doing a find and replace of everything with "gnome" to "mate" and got pretty close. I'll try and work on it some more today and post the results. 

Also need to talk to mate upstream about gnome-panel-control.. this is something we never forked.
Comment 11 Christoph Wickert 2013-12-10 13:21:52 EST
(In reply to Dan Mashal from comment #10)
> I spent time on this last night, basically doing a find and replace of
> everything with "gnome" to "mate" and got pretty close. I'll try and work on
> it some more today and post the results. 

Thanks, but no need to. It was indeed trivial, I have a working patch.

> Also need to talk to mate upstream about gnome-panel-control.. this is
> something we never forked.

It's not part of GNOME, so it was never forked.

Last question: Should I just rename all *gnome* stuff to *mate*? I can do this, but it requires some testing and I would appreciate your help.
Comment 12 Dan Mashal 2013-12-10 14:25:05 EST
(In reply to Christoph Wickert from comment #11)
> Last question: Should I just rename all *gnome* stuff to *mate*? I can do
> this, but it requires some testing and I would appreciate your help.

Yes please do and let me know. I will test. And for the desktop files you can use "X-Mate"
Comment 13 Miroslav Lichvar 2014-07-04 05:40:12 EDT
Any news on this?

I think I'll remove the gnome subpackages for now and if someone wants to convert them later to mate, please feel free.
Comment 14 Christoph Wickert 2014-07-07 10:25:21 EDT
Can we please not remove but properly obsolete them? I already have a patch ready, I am just waiting for feedback on the package name from Dan and the MATE folks.
Comment 15 Miroslav Lichvar 2014-07-07 10:41:31 EDT
Well, I think two Fedora releases including openbox subpackages with broken dependencies is more than enough. The removed subpackages are obsoleted by openbox and will be removed on upgrade if someone still have them installed.

If you can resurrect them for MATE, that's great. You can move the obsoleting lines there then.

Note You need to log in before you can comment on or make changes to this bug.