Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 965120 - JBoss Fails to Start in Domain Mode on Fedora 18
JBoss Fails to Start in Domain Mode on Fedora 18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jboss-as (Show other bugs)
18
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
: 965130 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 09:16 EDT by Mauricio Magnani Jr
Modified: 2013-06-04 23:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: jboss-as-7.1.1-19.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 23:18:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauricio Magnani Jr 2013-05-20 09:16:40 EDT
Description of problem:

JBoss fails to start in domain mode.

Version-Release number of selected component (if applicable):

jboss-as.noarch 0:7.1.1-17.fc18

How reproducible:

performed the installation with the command:

$ sudo yum install jboss-as –y

Edit configuration file /etc/jboss-as/jboss-as.conf and do as below:

# The configuration you want to run
JBOSS_CONFIG=domain.xml
# The address to bind to
JBOSS_BIND=0.0.0.0

edit the file service /usr/lib/systemd/system/jboss-as.service and changing the attribute ExecStart to use the script domain.sh

ExecStart=/usr/share/jboss-as/bin/domain.sh -c $JBOSS_CONFIG -b $JBOSS_BIND

run the command to reload the service settings:

$ sudo systemctl --system daemon-reload

Restart the JBoss

$ sudo systemctl restart jboss-as.service

The exception is thrown:

INFO  [org.jboss.modules] (main) JBoss Modules version 1.1.1.GA
01:36:38,453 ERROR [stderr] (main) java.lang.IllegalStateException: JBAS015859: Could not create servers directory: /usr/share/jboss-as/domain/servers
01:36:38,456 ERROR [stderr] (main)      at org.jboss.as.host.controller.HostControllerEnvironment.<init>(HostControllerEnvironment.java:397)
01:36:38,459 ERROR [stderr] (main)      at org.jboss.as.host.controller.Main.determineEnvironment(Main.java:392)

temporary solution

Edit the file /usr/share/jboss-as/bin/domain.conf and add:

JAVA_OPTS="$JAVA_OPTS -Djboss.domain.servers.dir=/tmp"

problem solved:

jboss-as.service - The JBoss Application Server
Loaded: loaded (/usr/lib/systemd/system/jboss-as.service; disabled)
Active: active (running) since Sat, 2013-05-18 01:40:11 EDT; 36s ago
Main PID: 3279 (domain.sh)
CGroup: name=systemd:/system/jboss-as.service
â 3279 /bin/sh /usr/share/jboss-as/bin/domain.sh -c domain.xml -b 0.0.0.0
â 3317 java -D[Process Controller] -server -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=tru...
â 3329 java -D[Host Controller] -Dorg.jboss.boot.log.file=/usr/share/jboss-as/domain/log/host-controller.log -Dlogging.configuration=file:/usr/sh...
â 3377 /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jre/bin/java -D[Server:server-one] -XX:PermSize=256m -XX:MaxPermSize=256m -Xms64m -Xmx512m...
â 3392 /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jre/bin/java -D[Server:server-two] -XX:PermSize=256m -XX:MaxPermSize=256m -Xms64m -Xmx512m..

Actual results:

Failed to start

Expected results:

Success at startup
Comment 1 Marek Goldmann 2013-05-21 06:42:23 EDT
*** Bug 965130 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2013-05-24 02:25:56 EDT
jboss-as-7.1.1-19.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/jboss-as-7.1.1-19.fc19
Comment 3 Fedora Update System 2013-05-24 15:47:57 EDT
Package jboss-as-7.1.1-19.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing jboss-as-7.1.1-19.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9086/jboss-as-7.1.1-19.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-06-04 23:18:32 EDT
jboss-as-7.1.1-19.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.