This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 965163 - Evolution fails to display emals,. forwarded as attachments (attachment.dat)
Evolution fails to display emals,. forwarded as attachments (attachment.dat)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.4
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 11:10 EDT by Assen Totin
Modified: 2013-07-02 05:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 05:50:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Email message, forwarded as attachment. (8.98 KB, text/plain)
2013-06-18 10:08 EDT, Assen Totin
no flags Details

  None (edit)
Description Assen Totin 2013-05-20 11:10:50 EDT
Description of problem:

Evolution fails to display (render) an email message which is forwarded as attachment to another (attachment.dat).

Version-Release number of selected component (if applicable):

evolution-2.28.3-30.el6.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. Have somebody who uses MS Outlook forward an email to you. The original email will be attached as 'attachment.dat' (RFC 822). The attached email may contain its own attachments. 
2. Check your mail in Evolution. 

Actual results:

The attached email is shown by Evo as 'attachment.dat'. It is not rendered. The file can be saved and open by GEdit or any other plin text editor. 

Expected results:

The attachment is available for view inline. 

Additional info:

Note: attachment.dat is NOT winmail.dat (not a TNEF attachment). It is plain text, RFC 822 compliant message as can be seen in any text editor. It may be similar to *.eml files(?).

The following workaround is known: right-click the 'attachment.dat' in Evo, then chose 'Forward". In the composer window the contents of the atachment,dat will be visible and any of its own attachments - present. You can now forward this to yourself and the result will be OK. Still, this is just a workaround. 

Since Evo obviously knows how to render the attachment.dat, it should be able to do so in the main viewing window.
Comment 1 Jaroslav Škarvada 2013-05-20 11:14:25 EDT
Probably wrong component, reassigning to evolution.
Comment 3 Milan Crha 2013-05-21 07:47:38 EDT
Thanks for a bug report. I currently do not have access to Outlook, unfortunately, thus could you sent a message test to yourself, forward it from outlook and attach is here (as saved from Evolution), please? By tje way, how do you receive the forwarded message? Is it throug IMAP, POP3, MAPI...?
Comment 4 Assen Totin 2013-06-18 10:08:41 EDT
Created attachment 762508 [details]
Email message, forwarded as attachment.
Comment 5 Assen Totin 2013-06-18 10:11:05 EDT
Hi, Milan,

This is an email message sent from GMail to my Exchnage 2008 account, then forwarded as attachment from Outlook 2010 to self and finally retrieved from Exchange by Evolution. 

My Evo uses DavMail (http://davmail.sourceforge.net) as IMAP-to-Exchange gateway since it crahes on every attempt to configure the Exchange account in Evolution. 

WWell,
Comment 6 Milan Crha 2013-06-20 09:37:59 EDT
Thanks for th eupdate. I tested with your message and evoluton-2.28.3 and it works as expected for me, the attached message is shown inline in message preview. I imported it into On This Computer/Inbox folder. I see in the message source (Ctrl+U) that the attached message's part has:
   Content-Type: message/rfc822

which makes it shown as expected. Could you check message source of other message, which doesn't work for you, what Content-Type the attached message part has, in the message source, please?

The DavMail is not a problem, though it would be good to know why and where evolution crashes for you when you try to configure an Exchange account. By the way, what is your exchange server version, please? The evolution-exchange is used for Exchange 2003 servers only, for any newer server use evolution-mapi, which uses different protocol to communicate with Exchange servers.
Comment 7 Assen Totin 2013-06-25 09:01:18 EDT
Hi, Milan,

Off-topic, Exchange is 2008 and I'm trying MAPI against it, but Evo crashes before account setup is completed (while in the new account wizard).

You are correct about importing the mail in 'On This Computer -> Inbox' - the mail can indeed be opened in the end of the message. From this point of view, my bug report seems incorrect; still, the user experience is unpleasent: 

- If the message is more than one screen long, I'll never see there is an 'arrow' marking which allows me to open the attached messages inline;

- Attachment is shown as 'attachment.dat' which is clearly incorrect (ther eare 1 or more email messages attached with their proper sender, subject etc.)

- If I double-click the attachment, it opens the email source in text viewer. 

From my (right now, end-user's) point of view: 

- There should be no 'attachment.dat' and the original message info should be visible (much like TNEF plugin works - it replaces the TNEF attachment with the actual attached file(s).)

- If clicked, such message should open in a message viewer and not in text editor (Evo know how to render the message and knows its MIME type, so why is it calling external application? Or maybe a systm default MIME handler should be added? But we have in Gnome 'Preferred Mail Application' already set...)
Comment 8 Milan Crha 2013-06-27 05:12:40 EDT
(In reply to Assen Totin from comment #7)
> Off-topic, Exchange is 2008 and I'm trying MAPI against it, but Evo crashes
> before account setup is completed (while in the new account wizard).

Thanks for the update. I suppose you mean Exchange 2007, probably with some Service Packs. Could you install debuginfo packages for evolution, evolution-mapi and openchange, and run evolution under gdb, then get a backtrace of the crash, just to see why it is crashing? There might be a fix for it, I only need to know where it crashed. Before attaching the backtrace here, make sure you'll not expose any provate data, because if it's crashing during connection to the server, then the backtrace may contain a password in a plain text. I usually search for "pass" (quotes for clarity only) in the backtrace. The command to run evolution under gdb may look like:
   $ gdb evolution --ex r --ex "t a a bt" --ex q

which runs evolution, and when it's stopped, possibly due to a crash, then it gets a backtrace for all threads, then it quits (will need a confirmation from you). It'll be good to provide not only result of the "t a a bt", but also other lines above the actual crash.

> You are correct about importing the mail in 'On This Computer -> Inbox' -
> the mail can indeed be opened in the end of the message. From this point of
> view, my bug report seems incorrect;

I would not tell that, maybe it was another email? Though if you only overlooked the opportunity of the bottom listed attachments, then I agree, this can be closed.

> still, the user experience is unpleasent: 
> 
> - If the message is more than one screen long, I'll never see there is an
> 'arrow' marking which allows me to open the attached messages inline;

I guess it looks weird on the first look, but once you get use to it, and know that all the attachments are either at the top (click the little [+] button), or listed one after another at the bottom, then you'll find it useful.

> - Attachment is shown as 'attachment.dat' which is clearly incorrect (ther
> eare 1 or more email messages attached with their proper sender, subject
> etc.)

I see, mine attachment is shown as "email message attachment" at the bottom, but as 'attachment.dat' at the top attachment bar. It's a default name when the part doesn't have its own name, where your mail from comment #4 doesn't provide filename for the attachment.

> - If I double-click the attachment, it opens the email source in text
> viewer. 

Yeah, the top attachment bar is to work with the attachment with an external application, while bottom shown attachment sare there to work with them inside evolution. As I wrote above, maybe once you get use to it you'll find it useful.

> From my (right now, end-user's) point of view: 

I explained this beside the above points.

-------------------------------------------------------------------------

If you are fine with the above, then I would close this, and we can try to figure out the mapi crash in another bug report, or keep the investigation in this bug report. I'll keep it up to you.
Comment 9 Assen Totin 2013-07-01 14:55:44 EDT
Thank you, Milan, I'm OK to close this case. 

As of the Exchange-related crash in Evo, I no longer have access to the Exchange server because moved to another company last week. I'm sorry I cant be of help here.
Comment 10 Milan Crha 2013-07-02 05:50:37 EDT
No problem. I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.