Bug 965164 - $HOME owned by root if a partition with mountpoint inside $HOME is created during install
$HOME owned by root if a partition with mountpoint inside $HOME is created du...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-initial-setup (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jasper St. Pierre
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 11:11 EDT by Sandro Mani
Modified: 2013-12-25 11:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-25 11:28:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mani 2013-05-20 11:11:34 EDT
Description of problem:
If, during install, the user creates a mountpoint inside the future $HOME, $HOME will be owned by root. This causes gnome to crash when logging in since $HOME is not writeable.

Version-Release number of selected component (if applicable):
anaconda-19.28-1.fc19.x86_64
gnome-initial-setup-0.10-1.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot live cd, start installation
2. Select to review/modify partitions (I've selected standard partition scheme, not LVM or BTRFS)
3. Automatically create the standard paritions (boot, root, swap), and add an other patition with mountpoint /home/$username/data, where $username is the future username
4. Begin the installation, but do not create any users at this point (but do in in gnome-initial-setup)
5. Reboot
6. gnome-initial-setup runs. Before completing the setup, quickly switch to a VT, login as root and do a stat /home/$username: it's owned by root
7. Finish the gnome-initial-setup
8. From a VT, again stat /home/$username: it's still owned by root
9. Attempt to login into gnome: noting happens, and you'll eventually find yourself looking at the login screen again (the cause obviously being that the home directory is not writeable). Also note that any files from /etc/skel are not copied into $HOME
Comment 1 Sandro Mani 2013-12-25 11:28:55 EST
Seems fixed now

Note You need to log in before you can comment on or make changes to this bug.