Bug 965206 - udisks-daemon using memory resources and restarts after being disabled
udisks-daemon using memory resources and restarts after being disabled
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udisks (Show other bugs)
6.3
All Linux
high Severity medium
: rc
: 6.6
Assigned To: Tomas Smetana
Desktop QE
: OtherQA
Depends On:
Blocks: 1159926 1172231 1269194
  Show dependency treegraph
 
Reported: 2013-05-20 13:40 EDT by tcleveng
Modified: 2017-03-21 07:45 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 07:45:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 710373 None None None Never

  None (edit)
Description tcleveng 2013-05-20 13:40:14 EDT
Description of problem:
Customers udev-daemon is using a substantial amount of system memory while polling for the sr0 (DVD device). Usual protocol for this as per knowledge article:
https://access.redhat.com/site/node/150443

would be to disable polling but daemon keeps returning after being disabled.

Version-Release number of selected component (if applicable):
udev-147-2.42.el6.x86_64                                    Thu 21 Jun 2012 12:54:41 PM EDT

How reproducible:
On customers environment reproducible... On test, not so much. As per Lawrence Obermans testing environment.

Steps to Reproduce:
1. Note memory usage for udev: ps -A --sort -rss -o pid,comm,pmem,rss |more
2. Manually disabling the polling using the --inhibit polling does not stop the memory growth.  The pid then needs to be killed, and after that the memory growth stops.
3.It comes alive again if a session is opened using a gui tool. (at least this has been my observation how I can manually re-create it).

Actual results:
Udev-daemon comes back after being disabled and starts to take memory again after a reboot or application start.

Expected results:
Udev-daemon stops polling for the sr0 (DVD device) and stops taking memory.

Additional info:
Lawrence Oberman, Jon Magrini, and I have tried numerous options including:
- udev rule to stop polling: Comment #67 Case 00777363
- Disabling Polling
- Custom scripts to stop daemon on reboot. (Workaround)
Comment 2 Harald Hoyer 2013-06-03 05:06:13 EDT
The udev daemon does not poll the cdrom and you must never kill the daemon.

You are referring to /usr/libexec/udisks-daemon, which is not udev related.
Comment 3 RHEL Product and Program Management 2013-10-13 19:35:51 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 16 Tomas Smetana 2016-04-01 10:22:35 EDT
There is no new information since the last time I asked for it... So, sorry, no news from me either. And again: udisks is required only by some desktop applications and if the customer does not need them, it's better to remove udisks from the system.

Do we know if there is a specific action making udisks to start consuming the memory? Do we have some userspace data? I was not able to find out much from the vmcore, perhaps an userspace udisks coredump might provide some clues.
Comment 27 Tomas Smetana 2016-04-19 09:12:50 EDT
I have run some more tests and the new built does not seem to suffer from the memory leaks at all in my tests.

The valgrind reported possible leaks were all originating from an initialization function so no matter how many events I produced the memory consumption remained at the same level. I had the test run for about two hours only however that was enough for the unpatched version to clearly show a constant memory consumption growth. I have uploaded the new builds (there are no code changes: just a changelog change) on the fedorapeople page for testing (and nothing else) since I found no more leaks to plug.
Comment 38 errata-xmlrpc 2017-03-21 07:45:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0778.html

Note You need to log in before you can comment on or make changes to this bug.