Bug 965255 - binutils can't cope with dwz's output
binutils can't cope with dwz's output
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 15:20 EDT by Adam Jackson
Modified: 2013-08-14 22:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: binutils-2.23.51.0.1-10.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 12:46:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
http://kojipkgs.fedoraproject.org/packages/pango/1.34.1/1.fc19/x86_64/pango-debuginfo-1.34.1-1.fc19.x86_64.rpm (730.00 KB, application/octet-stream)
2013-05-20 15:20 EDT, Adam Jackson
no flags Details

  None (edit)
Description Adam Jackson 2013-05-20 15:20:28 EDT
Created attachment 750696 [details]
http://kojipkgs.fedoraproject.org/packages/pango/1.34.1/1.fc19/x86_64/pango-debuginfo-1.34.1-1.fc19.x86_64.rpm

Description of problem:

Unpack the pango-debuginfo in the attachment, or equivalently:

http://kojipkgs.fedoraproject.org/packages/pango/1.34.1/1.fc19/x86_64/pango-debuginfo-1.34.1-1.fc19.x86_64.rpm

Then run 'objdump -Dl' over the debuginfo file for the DSO, and be sad:

% objdump -Dl pango-debuginfo-1.34.1-1.fc19.x86_64/usr/lib/debug/usr/lib64/libpango-1.0.so.0.3400.1.debug |& grep BFD | head -5
BFD: Dwarf Error: Invalid or unhandled FORM value: 7969.
BFD: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
BFD: Dwarf Error: found dwarf version '0', this reader only handles version 2, 3 and 4 information.
BFD: Dwarf Error: found dwarf version '56191', this reader only handles version 2, 3 and 4 information.
BFD: Dwarf Error: found dwarf version '6912', this reader only handles version 2, 3 and 4 information.

Locally rebuilding pango with %global _find_debuginfo_dwz_opts %{nil} produces a .debug file without this problem.

I'm not entirely sure what the rpmbuild-generated dwz command line comes out to.  My attempts to divine it from reading find-debuginfo.sh seem to result in output files that all work correctly.
Comment 1 Jakub Jelinek 2013-05-20 15:34:24 EDT
Looks like objdump bug.  readelf -wi handles this just fine.  FORM 7969 is valid (DW_FORM_GNU_strp_alt).
Comment 2 Nick Clifton 2013-05-29 11:49:13 EDT
I have checked in a patch (to rawhide) to add support in the BFD library for handling the alternate debuginfo files produced by the DWZ program.  Please try out: binutils-2.23.88.0.1-5.fc20 and let me know if the problem still exists.

Cheers
  Nick
Comment 3 Adam Jackson 2013-06-11 09:55:27 EDT
% objdump -Dl ~/dwz/pango-debuginfo-1.34.1-1.fc19.x86_64/usr/lib/debug/usr/lib64/libpango-1.0.so.0.3400.1.debug |& grep -c BFD   
0
% rpm -q binutils
binutils-2.23.88.0.1-6.fc20.x86_64

Looks good, thanks!
Comment 4 Adam Jackson 2013-06-18 12:46:36 EDT
Fixed in F20 is good enough for me, especially since the elfutils tools don't seem to have this issue.
Comment 5 Dan Horák 2013-06-20 11:28:25 EDT
Nick, can you backport the fix also to f19 (and maybe also f18) and release an update thru bodhi?
Comment 6 Fedora Update System 2013-06-21 06:00:27 EDT
binutils-2.23.52.0.1-9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/binutils-2.23.52.0.1-9.fc19
Comment 7 Fedora Update System 2013-06-21 06:05:04 EDT
binutils-2.23.51.0.1-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/binutils-2.23.51.0.1-10.fc18
Comment 8 Dan Horák 2013-06-21 07:50:59 EDT
thanks Nick, Dan
Comment 9 Fedora Update System 2013-06-29 14:15:55 EDT
binutils-2.23.52.0.1-9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-08-14 22:31:41 EDT
binutils-2.23.51.0.1-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.