Bug 965288 - Volume was not automounted by swift causing requests to the volume to fail
Volume was not automounted by swift causing requests to the volume to fail
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift (Show other bugs)
2.0
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Luis Pabón
pushpesh sharma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 16:13 EDT by Luis Pabón
Modified: 2016-11-08 17:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 22:52:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (3.87 KB, text/plain)
2013-05-20 16:20 EDT, Luis Pabón
no flags Details

  None (edit)
Description Luis Pabón 2013-05-20 16:13:28 EDT
Description of problem:
The request returned that the resource could not be found while trying to create a container on a known volume/account.  The issue is that the volume was not mounted by swift thus causing the error.  Once the volume was mounted manually, the request was able to create a container in the specified volume/account.
Comment 1 Luis Pabón 2013-05-20 16:17:59 EDT
Output of curl commands:
[pportant@gprfc019 Catalyst]$ curl -sS --connect-timeout 1 --write-out "%{http_code} %{time_total} %{url_effective}\n" -X PUT http://gprfs011:8080/v1/AUTH_test1/newcont
<html>
 <head>
  <title>404 Not Found</title>
 </head>
 <body>
  <h1>404 Not Found</h1>
  The resource could not be found.<br /><br />



 </body>
</html>404 0.474 http://gprfs011:8080/v1/AUTH_test1/newcont

[pportant@gprfc019 Catalyst]$ curl -sS --connect-timeout 1 --write-out "%{http_code} %{time_total} %{url_effective}\n" -X PUT http://gprfs011:8080/v1/AUTH_test1/newcont
<html>
 <head>
  <title>404 Not Found</title>
 </head>
 <body>
  <h1>404 Not Found</h1>
  The resource could not be found.<br /><br />



 </body>
</html>404 0.123 http://gprfs011:8080/v1/AUTH_test1/newcont

[pportant@gprfc019 Catalyst]$ curl -sS --connect-timeout 1 --write-out "%{http_code} %{time_total} %{url_effective}\n" -X PUT http://gprfs011:8080/v1/AUTH_catalyst/newcont
<html>
 <head>
  <title>404 Not Found</title>
 </head>
 <body>
  <h1>404 Not Found</h1>
  The resource could not be found.<br /><br />



 </body>
</html>404 0.119 http://gprfs011:8080/v1/AUTH_catalyst/newcont

*** At this point we did the following on the server:
* Create the directory with the same name as the volume under the mount point directory defined in /etc/swift/fs.conf
* Mount the glusterfs volume at the location of the directory

[pportant@gprfc019 Catalyst]$ curl -sS --connect-timeout 1 --write-out "%{http_code} %{time_total} %{url_effective}\n" -X PUT http://gprfs011:8080/v1/AUTH_catalyst/newcont
201 Created



   201 0.054 http://gprfs011:8080/v1/AUTH_catalyst/newcont
Comment 2 Luis Pabón 2013-05-20 16:20:25 EDT
Created attachment 750708 [details]
/var/log/messages
Comment 4 Luis Pabón 2013-06-05 22:52:41 EDT
Gluster for swift will not support automount of Gluster volumes.

Note You need to log in before you can comment on or make changes to this bug.