Bug 965296 - Headpin Nightly: Not able to subscribe a client using subscription-manager cli
Headpin Nightly: Not able to subscribe a client using subscription-manager cli
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tom McKay
sthirugn@redhat.com
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-05-20 16:35 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:10:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2013-05-20 16:35:39 EDT
Description of problem:
Not able to subscribe a client using subscription-manager cli

Version-Release number of selected component (if applicable):
* candlepin-0.8.7-1.el6.noarch
* candlepin-cert-consumer-ibm-x3655-02.ovirt.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-tomcat6-0.8.7-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.48.441089b.el6.noarch
* katello-cli-common-1.4.2-1.git.48.441089b.el6.noarch
* katello-common-1.4.2-1.git.352.c97daf2.el6.noarch
* katello-configure-1.4.3-1.git.21.0134f7d.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.352.c97daf2.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.352.c97daf2.el6.noarch
* katello-headpin-1.4.2-1.git.352.c97daf2.el6.noarch
* katello-headpin-all-1.4.2-1.git.352.c97daf2.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install headpin-nightly
2. Create an Organization org1 (No environments created since environment functionality is removed from headpin)
3. Register and subscribe a client to headpin server

# subscription-manager register --username=*** --password=*** --org=org1
Organization org1 has more than one environment. Please specify target environment for system registration.

# subscription-manager register --username=*** --password=*** --org=org1 --env=Library
Error: Server does not support environments.

Actual results:
Error is thrown as shown above

Expected results:
User should be able to register and subscribe a client

Additional info:
Comment 1 Tom McKay 2013-05-21 09:59:23 EDT
Orgs with more than one environment are not supported in headpin. The org in this test did have more than one. Confirmed worked registering against a single-env org.
Comment 2 Bryan Kearney 2013-06-06 17:05:46 EDT
ACK to what tom said, my guess is this was an upgrade issue. Which reminds me, we need to add a migration task for upgrades.
Comment 3 sthirugn@redhat.com 2013-07-05 15:48:14 EDT
Verified in latest headpin nightly:
# subscription-manager register --username user1 --password **** --org=org1
The system has been registered with id: d93c92d0-f5e4-4bce-8d5b-8884839edaf7 

Version Tested:
* candlepin-0.8.16-1.el6.noarch
* candlepin-cert-consumer-ibm-x3655-03.ovirt.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-tomcat6-0.8.16-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.107.43fee0b.el6.noarch
* katello-cli-common-1.4.2-1.git.107.43fee0b.el6.noarch
* katello-common-1.4.2-1.git.812.a3a58dc.el6.noarch
* katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.812.a3a58dc.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.812.a3a58dc.el6.noarch
* katello-headpin-1.4.2-1.git.812.a3a58dc.el6.noarch
* katello-headpin-all-1.4.2-1.git.812.a3a58dc.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch

Note: It was found that the original organization reported in the bug had few environments created via the APIs.
Comment 5 errata-xmlrpc 2013-10-01 07:10:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.