Bug 965310 - unable to delete distributor
unable to delete distributor
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
Nightly
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: Devan Goodwin
Tazim Kolhar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 17:22 EDT by Chris Duryee
Modified: 2016-04-25 20:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:23:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalina.out (20.19 KB, text/plain)
2013-05-21 10:59 EDT, Adam Price
no flags Details

  None (edit)
Description Chris Duryee 2013-05-20 17:22:17 EDT
Description of problem:

unable to delete distributors that are linked to other orgs

Version-Release number of selected component (if applicable): nightly

katello-1.4.2-1.git.411.375f44b.el6.noarch
candlepin-0.8.7-1.el6.noarch

How reproducible:

every time (both me and adprice)

Steps to Reproduce:

all steps can be done via web ui, but the bug also occurs via API/katello-cli

1. create a new org, let's say org B
2. create a distributor in your acme org
3. export a manifest from the new distributor, it doesn't need to have any subs on it
4. import the manifest into org B
5. go back to acme org, attempt to delete distributor


Actual results: 500 error from candlepin


Expected results: successful deletion


Additional info: I'm not sure if this is a katello bug or candlepin bug.
Comment 1 Adam Price 2013-05-21 10:59:47 EDT
Created attachment 751199 [details]
catalina.out

full catalina.out stacktrace
Comment 2 Devan Goodwin 2013-05-23 09:21:54 EDT
Fixed in candlepin.git master: bee7aa8b83326c055de39d5b204ab7e98e6ad9ab

Will appear in: candlepin-0.8.8-1
Comment 3 Sam Kottler 2013-05-23 19:40:49 EDT
Moving to ON_QA for drop 2.
Comment 4 Tazim Kolhar 2013-05-28 05:06:53 EDT
VERIFIED

# rpm -qa | grep katello
ruby193-rubygem-foreman-katello-engine-0.0.7-1.el6sat.noarch
katello-common-1.4.2-7.el6sat.noarch
katello-1.4.2-7.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
katello-glue-candlepin-1.4.2-7.el6sat.noarch
katello-configure-foreman-1.4.3-10.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.2-6.el6sat.noarch
signo-katello-0.0.12-1.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-glue-pulp-1.4.2-7.el6sat.noarch
katello-all-1.4.2-7.el6sat.noarch
katello-foreman-all-1.4.2-7.el6sat.noarch
katello-cli-common-1.4.2-6.el6sat.noarch
katello-glue-elasticsearch-1.4.2-7.el6sat.noarch
katello-configure-1.4.3-10.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.1-1.el6_4.noarch
Comment 5 Mike McCune 2013-07-18 17:23:14 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.