Bug 965320 - Page titles inconsistent between Katello and Foreman
Page titles inconsistent between Katello and Foreman
Status: CLOSED DUPLICATE of bug 1099469
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Tomas Strachota
Sachin Ghai
: Triaged
Depends On:
Blocks: 1099463
  Show dependency treegraph
 
Reported: 2013-05-20 18:56 EDT by Dominic Cleal
Modified: 2014-06-16 17:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1099463 1099469 (view as bug list)
Environment:
Last Closed: 2014-06-16 17:41:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominic Cleal 2013-05-20 18:56:46 EDT
Description of problem:
The page titles (i.e. <title>) are inconsistent with the Katello/Content half of the application.

On the Katello Dashboard it reads "Red Hat Satellite 6 - Content and Entitlement" (though doesn't appear to change across pages)

On the Foreman Dashboard it reads "Welcome" (and changes based on the page)


Version-Release number of selected component (if applicable):
foreman-1.1.10002-29.noarch
katello-1.4.2-6.el6sat.noarch
katello-all-1.4.2-6.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.2-5.el6sat.noarch
katello-cli-common-1.4.2-5.el6sat.noarch
katello-common-1.4.2-6.el6sat.noarch
katello-configure-1.4.3-9.el6sat.noarch
katello-configure-foreman-1.4.3-9.el6sat.noarch
katello-foreman-all-1.4.2-6.el6sat.noarch
katello-glue-candlepin-1.4.2-6.el6sat.noarch
katello-glue-elasticsearch-1.4.2-6.el6sat.noarch
katello-glue-pulp-1.4.2-6.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.3-3.el6sat.noarch


How reproducible:
Always

Steps to Reproduce:
1. Load Katello dashboard and check the title
2. Load Foreman dashboard and check the title

Actual results:
Katello Dashboard reads "Red Hat Satellite 6 - Content and Entitlement"
Foreman Dashboard reads "Welcome"

Expected results:
Similar titles, preferably branded as per the product component names.
Comment 2 Dominic Cleal 2013-10-02 06:40:02 EDT
To be handled as a downstream-only patch.
Comment 5 Mike McCune 2013-10-17 16:59:37 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 8 Sachin Ghai 2014-05-13 05:11:00 EDT
Verified with Satellite 6 Beta Snap 4 (Satellite-6.0.3-RHEL-6-20140508.1)


I checked titles for almost all product component names. And UI shows same as the product component name is. Like if I select 'Sync Plans' the page title shows 'Sync Plans'

However, I found some inconsistency with following three components selection:

1. Select Monitor --> Statistics: In this case Page title should show 'Statistics'

However UI shows: https:<hostname>/Statistics

2. Select Content -> 'Red Hat Subscriptions' : Title shows katello
3.  Select Content -> 'Red Hat Repositories' : Title shows katello

I think we should make it consistent across all product components.
Comment 10 Bryan Kearney 2014-06-05 16:21:19 EDT
downstream only patch
Comment 11 Mike McCune 2014-06-16 17:41:00 EDT

*** This bug has been marked as a duplicate of bug 1099469 ***

Note You need to log in before you can comment on or make changes to this bug.