Bug 965345 - RFE Interoperability between different protocols (REST, Memcached, Embedded)
RFE Interoperability between different protocols (REST, Memcached, Embedded)
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 6.2.0
Assigned To: gsheldon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 21:19 EDT by Misha H. Ali
Modified: 2014-01-15 19:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 19:03:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gsheldon: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2013-05-20 21:19:45 EDT
Read and write data from clients with different protocols.
Comment 1 gsheldon 2013-05-30 22:22:30 EDT
https://issues.jboss.org/browse/ISPN-2281
Comment 2 gsheldon 2013-06-12 02:22:54 EDT
Interoperability chapter added to the Developer Guide.

3 topics so far.
Comment 12 Martin Gencur 2013-12-19 08:33:06 EST
20.3. Protocol Interoperability

- Enable Compatibility Mode Declaratively

This code snippet is for server mode. It's not applicable to library JDG. We should mention that this is a configuration for server.

- Enable Compatibility Mode Programmatically

This is in turn relevant only for library JDG, not for server. We should mention that this is only for Library mode and potentially provide
also a declarative configuration for library mode.

Question? Why are all these comments private?
Comment 13 Martin Gencur 2013-12-19 08:45:13 EST
20.3.2. Protocol Interoperability Over REST

This is quite a useful topic but personally I would rename it to something like "Reading Data Over Rest In Compatibility Mode". Of course, there could be much more information added. In this case, though, I think it'd be best to point users to some tests in upstream because there are so many combinations of types of data that it's hard to describe via plain text, and time consuming.

20.3.3. Protocol Interoperability Using the Command Line Interface

I don't understand the topic much. It should precisely specify where the options must be set. It also mentions "ispncon" which is a tool we don't support.
Comment 16 Divya Mehra 2013-12-19 10:14:11 EST
Martin,

Could you please suggest any updates to 
20.3.2. Protocol Interoperability Over REST, per your comment 13
Comment 17 Martin Gencur 2013-12-19 10:36:48 EST
OK, the only change I suggest is changing the sentence starting with "If custom objects have been serialized and stored via the remote cache, these can ..." to "If custom objects have been serialized and stored via the embedded or remote cache, these can ..."

Let's not complicate it now.
Comment 21 gsheldon 2013-12-19 17:27:23 EST
Thanks for your prompt feedback Martin and Divya and thank you for implementing them Mandar.

FYI Martin, as a general rule we set to comments to Private when linking to internal tools like the docbuilder. 

Martin and Divya are any further changes required? 

I will set this to ON QA once the docs are brewed later today if there are no further changes.
Comment 22 Martin Gencur 2013-12-20 07:25:05 EST
Looks good now.
Comment 23 Mandar Joshi 2013-12-20 08:24:11 EST
Setting this bug to ON_QA.

Please move this bug to Verified if there are no further changes.
Comment 24 Misha H. Ali 2014-01-15 19:03:09 EST
The fix for this bug is now generally released and available here:

https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Data_Grid/6.2/index.html

Note You need to log in before you can comment on or make changes to this bug.