Bug 965346 - RFE: Query using Hot Rod and Java (Tech Preview)
RFE: Query using Hot Rod and Java (Tech Preview)
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 6.2.0
Assigned To: gsheldon
:
: 1037886 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 21:24 EDT by Misha H. Ali
Modified: 2014-01-15 19:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 19:03:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2013-05-20 21:24:33 EDT
Remote Query API using Hot Rod with Java (Tech Preview)
Comment 3 Misha H. Ali 2013-10-15 21:13:16 EDT
Emailed tristan about instructions to make this feature work. Lots of design documents linked at the tracking JIRA and smaller JIRAs within the tracking JIRA.
Comment 6 Mircea Markus 2013-10-30 11:14:59 EDT
There's no community documentation for this yet, better to handle this once the community documentation is available. Corresponding community JIRA is ISPN-3615
Comment 8 Mircea Markus 2013-11-18 19:46:52 EST
this commit adds detailed user documentation for the new query DSL:https://github.com/infinispan/infinispan/commit/7060fb0eeb76b7e223024246c05d82f40a816399
Comment 9 gsheldon 2013-11-24 20:42:35 EST
This chapter should also include information about all available operations in the DSL.

Email sent to anistor for more information.
Comment 11 Misha H. Ali 2013-12-03 21:09:56 EST
Divya's feedback for this content:

More work needed to get the flow right in Remote Querying chapter.

1) The chapter starts with using DSL in Embedded Querying.
This is not the primary use case.

Chapter should primarily discuss Querying over Hot Rod
and show Step-by-Step how to configure and write a Hot Rod client which performs Remote Queries.

(Use of same DSL in Library mode can be discussed in a final section.)


2) >>6.2. Protobuf Marshaller
The Infinispan Query DSL can be used remotely via the Hot Rod client. In order to do this, protocol buffers are used to adopt a common format for storing cache entries and marshalling them. 

Need more background - what is the Protobuf format? 

3) Protobuf requires data to be structured. This is achieved by declaring Protocol Buffer message types in .proto files 

Where are the .proto files located - client or server side ? Which directory?

4) 6.3. Performing Remote Queries via the Java Hot Rod Client
This section should be earlier in my view - as the primary use case is Querying over Hot Rod.

5) Add .jar Files
Add the following .jar files.

    Add the DSL .jar to the client's classpath. <---- which Jar file ?
    Add the infinispan-remote-query-server.jar to the server's classpath.
    Add the infinispan-remote-query-client.jar to both the client and the server's classpath.
Comment 12 Misha H. Ali 2013-12-03 21:11:02 EST
*** Bug 1037886 has been marked as a duplicate of this bug. ***
Comment 13 gsheldon 2013-12-04 23:54:30 EST
Setting Needinfo for Anistor to follow up on some of the questions above re: file locations.
Comment 14 gsheldon 2013-12-10 21:31:07 EST
Setting needinfo for mgencur.
Comment 19 Misha H. Ali 2014-01-15 19:03:12 EST
The fix for this bug is now generally released and available here:

https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Data_Grid/6.2/index.html

Note You need to log in before you can comment on or make changes to this bug.