Bug 965357 - Got bash errors when sshing into a gear on INT
Got bash errors when sshing into a gear on INT
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
: 965827 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 22:26 EDT by Jianwei Hou
Modified: 2015-05-14 19:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:06:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2013-05-20 22:26:11 EDT
Description of problem:
Create an app and ssh into the gear, some bash errors are displayed on ssh connection.

Version-Release number of selected component (if applicable):
On INT(not reproducible on devenv_3251)

How reproducible:
Always

Steps to Reproduce:
1. Create a gear
rhc app create phptest php-5.3
2. rhc app-ssh phptest


Actual results:
After step 2:
Warning: Permanently added 'phptest-jhou.int.rhcloud.com,23.22.107.119' (RSA) to the list of known hosts.
bash: cat: command not found
bash: cat: command not found
[phptest-jhou.int.rhcloud.com 519ad96f6cec0ef602000001]\> ls
bash: ls: command not found


Expected results:
Should not have such problem

Additional info:
Comment 1 Paul Morie 2013-05-21 13:33:16 EDT
The root cause (apparently) is that the /etc/openshift/env/PATH file contains an export statement in INT.  I am double-checking with operations; we will likely need to add a note to the release ticket to have this file changed to a raw value.
Comment 2 Paul Morie 2013-05-21 14:21:00 EDT
PR submitted.
Comment 3 openshift-github-bot 2013-05-21 15:50:16 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/ec6f6faf3efd21076dba013c9b34828f405dcc9e
Fix bug 965357: add guard against export in PATH in rhcsh
Comment 4 Paul Morie 2013-05-21 15:56:38 EDT
This will be fixed after the next INT deployment.
Comment 5 Jhon Honce 2013-05-21 17:04:35 EDT
*** Bug 965827 has been marked as a duplicate of this bug. ***
Comment 6 Jianwei Hou 2013-05-23 22:03:02 EDT
This is verified on INT(devenv_3266)

The error with the 'PATH' env var is fixed.

[jenkins1-jhou1.int.rhcloud.com 519590486cec0e7ba800038c]\> echo $PATH
:/bin:/usr/bin:/usr/sbin

Note You need to log in before you can comment on or make changes to this bug.