Bug 965358 - anaconda on MATE live image is missing almost all icons
anaconda on MATE live image is missing almost all icons
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-icon-theme (Show other bugs)
19
x86_64 All
unspecified Severity medium
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On: 965365
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 22:28 EDT by Adam Williamson
Modified: 2013-06-14 00:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-icon-theme-1.6.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 00:54:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-05-20 22:28:35 EDT
When you run anaconda on the MATE live image, almost all icons are missing - the icons for each spoke on the hub, icons on the date/time spoke, lots of icons missing.

I think what's going on here is that the 'symbolic' icons anaconda expects are present only in the GNOME icon theme. They are not in hicolor, which is the kind of 'universal fallback'. The GNOME theme isn't a default fallback or anything.

I *think* the way to fix this would be to have the MATE icon theme Inherits: gnome, but I'm looking into it in more detail ATM.
Comment 1 Adam Williamson 2013-05-20 23:09:08 EDT
Okay, so I still think that's more or less what we need to.

I was confused for a bit as to how this works on KDE, as the Oxygen icon theme does not inherit GNOME, but it turns out xsettings-kde does this:

xsettings_manager_set_string(managers[i], "Net/FallbackIconTheme", "gnome");

i.e. it sets the XSetting Net/FallbackIconTheme to 'gnome', so basically it sets up the GNOME theme as a fallback.

I'm not sure if it's better for MATE to do that, or just have the MATE icon theme inherit GNOME, or do something else entirely, or if they think this shouldn't be fixed and anaconda shouldn't be using random icons from GNOME's icon theme. Might be worth asking upstream.
Comment 2 Adam Williamson 2013-05-20 23:34:01 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=965365 would fix this, if anaconda does it, and probably save MATE having to do anything. Let's keep an eye on that.
Comment 3 Wolfgang Ulbrich 2013-05-21 04:08:37 EDT
Dan,
i did a pull request which add symbolic icons to mate-icon-theme (Menta) at upstream, 2 weeks ago.
https://github.com/mate-desktop/mate-icon-theme/pull/8
Asked Stefano for merging and for a new release.
Anaconda isn't the only GTK3 application which needs this icons in MATE.
Comment 4 Dan Mashal 2013-05-21 12:57:52 EDT
(In reply to Wolfgang Ulbrich from comment #3)
> Dan,
> i did a pull request which add symbolic icons to mate-icon-theme (Menta) at
> upstream, 2 weeks ago.
> https://github.com/mate-desktop/mate-icon-theme/pull/8
> Asked Stefano for merging and for a new release.
> Anaconda isn't the only GTK3 application which needs this icons in MATE.

This is a known issue not related to MATE.
Comment 5 Adam Williamson 2013-05-21 14:10:07 EDT
Well, not really. It's one of those bugs that has multiple ways of looking at it. There are two possible cures to the symptom 'the icons don't appear on the MATE live image': fix anaconda to force use of the GNOME icon theme, or have the MATE icon theme work in this scenario somehow (there are many ways of doing that).

Wolfgang is saying that doing the latter is something that should happen as well as fixing anaconda, basically: mate-icon-theme is having the -symbolic icons added to it upstream (which is one of the ways of making this work from the MATE side).

We could convert this bug to being a bug for adding the -symbolic icons to mate-icon-theme, or we could leave this bug as being for the symptom, and close it as soon as _either_ of the fixes happens (either mate-icon-theme grows the -symbolic icons, or anaconda starts forcing the use of the GNOME icon theme).
Comment 6 Fedora Update System 2013-06-11 08:01:54 EDT
mate-icon-theme-1.6.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-icon-theme-1.6.1-1.fc19
Comment 7 Fedora Update System 2013-06-11 13:55:56 EDT
Package mate-icon-theme-1.6.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-icon-theme-1.6.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10568/mate-icon-theme-1.6.1-1.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-06-14 00:54:00 EDT
mate-icon-theme-1.6.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.