Bug 965389 - Invalid dependencies will interrupt the building process for php perl and zend app
Invalid dependencies will interrupt the building process for php perl and zen...
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 03:01 EDT by Meng Bo
Modified: 2015-05-14 19:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 11:06:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-05-21 03:01:12 EDT
Description of problem:
Add some dependencies into the deplist.txt for php/perl app which is invalid or cannot be found from the mirrors. Git push the app will get some error, and the building will be interrupted. 

Version-Release number of selected component (if applicable):
devenv_3252

How reproducible:
always

Steps to Reproduce:
1.Create php/perl/zend app
2.Add some random strings in to deplist.txt
3.Git push the changes

Actual results:
Build will be interrupted because cannot find the packages from the mirror, and the app becomes to stopped status since it stopped the app in the beginning of building.

Expected results:
The unresolvable dependencies should be skipped and should not impact the building process. 

Additional info:

[bmeng@localhost phpstop]$ git push
Counting objects: 5, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (2/2), done.
Writing objects: 100% (3/3), 247 bytes, done.
Total 3 (delta 1), reused 0 (delta 0)
remote: Stopping PHP cart
remote: [Tue May 21 01:48:01 2013] [warn] module php5_module is already loaded, skipping
remote: Checking pear: test
remote: 
remote: No releases available for package "pear.php.net/test"
remote: install failed
remote: An error occured executing the 'postreceive' command. For more details about the problem, try running the command again with the '--trace' option.
To ssh://5195e0fc03ef64c614000017@phpstop-bmeng1int.int.rhcloud.com/~/git/phpstop.git/
   c901fdf..cda6335  master -> master


And for v1 cartridge, the invalid dependencies will not make the build fail.
Comment 1 nsun 2013-05-21 04:58:18 EDT
I have test case (ID:122848):PHP app libraries cleanup using force_clean_build marker, also found this error .
When I added 'channel://pear.php.net/Validate-0.8.4' to deplist.txt. 
The first 'git push' will be ok.
But the second 'git push' will be can't trigger action_hook script 'deploy'
Comment 2 Jhon Honce 2013-05-21 11:06:00 EDT
The application developer called out dependencies they are using in their application, skipping the dependencies would imply a "successful" build but the application would fail to run.  The build failure makes the failure easier to debug.

Note You need to log in before you can comment on or make changes to this bug.