Bug 965410 - "dnf clean expire-cache" does not have any effect
"dnf clean expire-cache" does not have any effect
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 04:13 EDT by Michal Schmidt
Modified: 2014-09-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: hawkey-0.3.13-2.git15db39f.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 00:38:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2013-05-21 04:13:02 EDT
Description of problem:
Sometimes when I run "dnf update", it reports there's nothing to do, even though "yum update" can see some available updates. Using wireshark I checked that dnf did not try to communicate to the network. I guess it believes it has all the metadata up to date. This in itself may be reasonable behaviour if the metadata were updated not so long ago. When I know that this dnf's assumption is incorrect, I expect to be able to perform "dnf clean expire-cache" to ensure dnf will re-check the freshness of the metadata in a subsequent "dnf update" invocation. However, "dnf clean expire-cache" does not seem to have any effect. It always says "0 metadata files removed". "dnf update" still won't see any new updates afterwards.


Version-Release number of selected component (if applicable):
dnf-0.3.4-1.git03fd687.fc19.noarch
librepo-0.0.4-1.fc19.x86_64
hawkey-0.3.11-1.gitffe0dac.fc19.x86_64
libsolv-0.3.0-3.git7399ad1.fc19.x86_64


How reproducible:
100%

Steps to Reproduce:
1. dnf clean expire-cache


Actual results:
Cleaning repos: adobe-linux-x86_64 fedora rpmfusion-free rpmfusion-free-updates
              : rpmfusion-free-updates-testing updates updates-testing
0 metadata files removed


Expected results:
Some metadata files removed (the tiny ones, i.e. "metalinks?").


Additional information:
"dnf clean metadata" works fine, but this is a more expensive operation, because it forces dnf to download all the big metadata files again, even though it previously had current versions of some of them. It says:

Cleaning repos: rpmfusion-free-updates-testing updates-testing fedora
              : rpmfusion-free-updates adobe-linux-x86_64 rpmfusion-free updates
34 metadata files removed
15 dbcache files removed
0 metadata files removed
Comment 1 Ales Kozumplik 2013-05-21 06:38:43 EDT
Hi, thanks for the report, I'll look into this.
Comment 2 Ales Kozumplik 2013-05-21 10:12:36 EDT
Hm, this is because DNF in F19 no longer relies on the 'cachecookie' file existing for each repo. The information about forced expiry between sessions has to be stored in some other way.
Comment 3 Ales Kozumplik 2013-05-24 08:53:24 EDT
Fixed by 20b776b, will be included in dnf-0.3.6.
Comment 4 Fedora Update System 2013-05-27 09:21:29 EDT
hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.6-1.git24ce938.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dnf-0.3.6-1.git24ce938.fc19,hawkey-0.3.13-2.git15db39f.fc19
Comment 5 Fedora Update System 2013-05-27 13:03:31 EDT
Package hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.6-1.git24ce938.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.3.13-2.git15db39f.fc19 dnf-0.3.6-1.git24ce938.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9385/dnf-0.3.6-1.git24ce938.fc19,hawkey-0.3.13-2.git15db39f.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-05-29 13:48:44 EDT
Package hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.7-1.gitf8bdc98.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.3.13-2.git15db39f.fc19 dnf-0.3.7-1.gitf8bdc98.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9385/hawkey-0.3.13-2.git15db39f.fc19,dnf-0.3.7-1.gitf8bdc98.fc19
then log in and leave karma (feedback).
Comment 7 Pavel Lisý 2013-05-30 02:41:22 EDT
It is working now (release 0.3.6-1)

# dnf list | grep dnf
dnf.noarch                             0.3.6-1.git24ce938.fc19   @System        
# dnf clean expire-cache
Vyčištění repozitářů:rpmfusion-nonfree-updates-testing
                   : rpmfusion-free-updates-testing updates-testing fedora
                   : rpmfusion-free-updates adobe-linux-x86_64
                   : rpmfusion-nonfree-updates rpmfusion-free updates
                   : rpmfusion-nonfree
The enabled repos were expired

Thanks
Comment 8 Fedora Update System 2013-06-07 00:38:00 EDT
hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.7-1.gitf8bdc98.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.