Bug 965415 - Bugzilla tries to write to shadow db
Bugzilla tries to write to shadow db
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Email Notifications (Show other bugs)
4.4
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 04:28 EDT by Petr Matousek
Modified: 2014-10-12 18:50 EDT (History)
11 users (show)

See Also:
Fixed In Version: 4.4rc2-3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 03:09:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Matousek 2013-05-21 04:28:39 EDT
Description of problem:

Bugzilla reports:

DBD::mysql::db do failed: The MySQL server is running with the --read-only option so it cannot execute this statement [for Statement "INSERT INTO tokens (userid, issuedate, token, tokentype, eventdata)
        VALUES (?, NOW(), ?, ?, ?)"] at Bugzilla/Token.pm line 418
	Bugzilla::Token::_create_token(164808, 'cc_unsubscribe', 962949) called at Bugzilla/Token.pm line 396
	Bugzilla::Token::issue_cc_remove_token('Bugzilla::User=HASH(0x7d77f50)', 'Bugzilla::Bug=HASH(0x7d63290)') called at Bugzilla/BugMail.pm line 425
	Bugzilla::BugMail::sendMail('HASH(0x7881260)') called at Bugzilla/BugMail.pm line 274
	Bugzilla::BugMail::Send(962949, 'HASH(0x7e52dd0)', 'HASH(0x7e6efb0)') called at Bugzilla/Bug.pm line 1472
	Bugzilla::Bug::_send_bugmail('HASH(0x7e6efb0)', 'HASH(0x6be9b30)') called at Bugzilla/Bug.pm line 1437
	Bugzilla::Bug::send_changes('Bugzilla::Bug=HASH(0x6e4a190)', 'HASH(0x6c108f0)', 'HASH(0x6be9b30)') called at /var/www/html/bugzilla/process_bug.cgi line 512


Version-Release number of selected component (if applicable):
Current production version

How reproducible:

No idea. This happened to me when moving bz962792 to CLOSED:ERRATA state. Because the bug has ~120 (non-RH) people on the CC list, I don't want to move back to NEW and test again.

Strangely enough, the bug changed it's state to CLOSED:ERRATA despite the error message.

Actual results:

Error message is reported.


Expected results:

No error message is shown.
Additional info:
Comment 1 Simon Green 2013-05-21 18:29:39 EDT
This error has been reported many times, so I need to get to the bottom of it. Unfortunately, I'm not exactly sure of where the problem is.

As a background, Red Hat have an extension that adds a remove me from the CC: list that uses a token to authenticate. The error occurs when generating this token. It appears that it is trying to put the token on the slave database, and not the master.

This only started occurring in Red Hat Bugzilla 4.4, so something has changed since 4.2.5-8 and this release.
Comment 3 wangjing 2013-05-22 05:09:26 EDT
Verified on qe test env version 4.4.rc2-3.1(20130522) --> pass

Verify steps:
1. login as redhat account.
2. visit show bug page of bug 560484 which has 688 users in cc list.
3. change the status of this bug to 'Assigned' and click 'save changes'.
then expected results:
large quantity email notifications message displaying on the top, and the status has been set to 'Assigned' without errors.

4. edit the cc list to remove one account, and meantime change the status of this bug to 'CLOSED:ERRATA' and click 'save changes'.

then expected results:
large quantity email notifications message displaying on the top, and the status has been set to 'CLOSED:ERRATA' without errors. 

Actual results:
same with expected results.

Note You need to log in before you can comment on or make changes to this bug.