Bug 965419 - su should create /run/user/$UID while login
su should create /run/user/$UID while login
Status: CLOSED DUPLICATE of bug 753882
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On: 961235 985016
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 04:40 EDT by Patrik Kis
Modified: 2013-07-16 10:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 14:19:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 961510 None None None Never

  None (edit)
Description Patrik Kis 2013-05-21 04:40:21 EDT
Description of problem:
When an user logs in a run time directory should be created for it in /run/user.
Similar sudo bug 961510.

Version-Release number of selected component (if applicable):
util-linux-2.23-1.fc19

How reproducible:
always

Steps to Reproduce:
[root@fed1 ~]# su - pkis
[pkis@fed1 ~]$ ls /run/user/
0
[pkis@fed1 ~]$ exit
logout
[root@fed1 ~]# su pkis
Last login: Tue May 21 10:33:29 CEST 2013 on pts/0
[pkis@fed1 root]$ ls /run/user/
0
[pkis@fed1 root]$ exit
exit
[root@fed1 ~]# su -c "ls /run/user/" pkis
Last login: Tue May 21 10:33:40 CEST 2013 on pts/0
0
[root@fed1 ~]# su -c "ls /run/user/" - pkis
Last login: Tue May 21 10:38:19 CEST 2013 on pts/0
0
[root@fed1 ~]# 

Actual results:
No directory is created for user in /run/user

Expected results:
A directory is created.
Comment 1 Karel Zak 2013-05-21 12:26:27 EDT
I don't see a reason why programs like su(1) or sudo(1) should create any random files... If we really want this functionality then it has to be implemented on one place and controlled by some config file -- for example by PAM module, or by logind, etc.
Comment 2 Tomas Mraz 2013-05-21 14:17:55 EDT
I'm sorry but this is really duplicate of bug 753882 which was closed by Lennart.
Comment 3 Tomas Mraz 2013-05-21 14:19:40 EDT

*** This bug has been marked as a duplicate of bug 753882 ***

Note You need to log in before you can comment on or make changes to this bug.