Bug 965432 - edit-node should offer fallback if isoname doesn't follow NVRA
edit-node should offer fallback if isoname doesn't follow NVRA
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 04:55 EDT by Fabian Deutsch
Modified: 2013-11-28 06:57 EST (History)
6 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 06:57:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 14970 None None None Never

  None (edit)
Description Fabian Deutsch 2013-05-21 04:55:12 EDT
Description of problem:
edit-node currently expects the filename of the original iso file to follow NVRA naming scheme, but it's not always the cased.
edit-node should have a fallback mechanism if the detection of NVRA (and buiölding the new iso name) fails.

The error looks like (with e.g. rhevh.iso):

Traceback (most recent call last):
File "./git/ovirt-node/tools/edit-node", line 1637, in <module>
  sys.exit(main())
File "./git/ovirt-node/tools/edit-node", line 1526, in main
  finished_iso = build_isoname_for_plugins(edited_iso, [n])
File "./git/ovirt-node/tools/edit-node", line 1614, in build_isoname_for_plugins
  nvra = isoname_to_nvr(editname_prefix)
File "./git/ovirt-node/tools/edit-node", line 1584, in isoname_to_nvr
  return filename_to_nvra(newfn)
File "./git/ovirt-node/tools/edit-node", line 1565, in filename_to_nvra
  v = nvra_.pop()
IndexError: pop from empty list
Comment 1 Fabian Deutsch 2013-05-22 05:05:35 EDT
http://gerrit.ovirt.org/#/c/14970/

Note You need to log in before you can comment on or make changes to this bug.