Bug 965487 - maildrop package should be built with PIE flags
maildrop package should be built with PIE flags
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: maildrop (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bruno Wolff III
Fedora Extras Quality Assurance
:
: 965488 965491 965493 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 05:56 EDT by Dhiru Kholia
Modified: 2014-03-24 23:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: maildrop-2.6.0-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 23:44:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dhiru Kholia 2013-05-21 05:56:40 EDT
Description of problem:

http://fedoraproject.org/wiki/Packaging:Guidelines#PIE says that "you MUST
enable the PIE compiler flags if your package has suid binaries...".

However, currently maildrop is not being built with PIE flags. This is a
clear violation of the packaging guidelines.

This issue (in its wider scope) is being discussed at,

https://fedorahosted.org/fesco/ticket/1104

https://lists.fedoraproject.org/pipermail/devel/2013-March/180827.html

Version-Release number of selected component (if applicable):

maildrop-2.6.0-1.fc19.x86_64.rpm

How reproducible:

You can use following programs to check if a package is hardened:

http://people.redhat.com/sgrubb/files/rpm-chksec

OR

https://github.com/kholia/checksec

Steps to Reproduce:

Get scanner.py from https://github.com/kholia/checksec

$ ./scanner.py maildrop-2.6.0-1.fc19.x86_64.rpm
maildrop,maildrop-2.6.0-1.fc19.x86_64.rpm,/usr/bin/deliverquota,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
maildrop,maildrop-2.6.0-1.fc19.x86_64.rpm,/usr/bin/lockmail,mode=0106755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
maildrop,maildrop-2.6.0-1.fc19.x86_64.rpm,/usr/bin/mailbot,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
maildrop,maildrop-2.6.0-1.fc19.x86_64.rpm,/usr/bin/maildirmake,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
maildrop,maildrop-2.6.0-1.fc19.x86_64.rpm,/usr/bin/maildrop,mode=0106755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
maildrop,maildrop-2.6.0-1.fc19.x86_64.rpm,/usr/bin/makedatprog,mode=0100755,NX=Enabled,CANARY=Disabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=NA,CATEGORY=None
maildrop,maildrop-2.6.0-1.fc19.x86_64.rpm,/usr/bin/makemime,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
maildrop,maildrop-2.6.0-1.fc19.x86_64.rpm,/usr/bin/reformail,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
maildrop,maildrop-2.6.0-1.fc19.x86_64.rpm,/usr/bin/reformime,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
Comment 1 Dhiru Kholia 2013-05-21 06:19:17 EDT
*** Bug 965488 has been marked as a duplicate of this bug. ***
Comment 2 Dhiru Kholia 2013-05-21 06:19:25 EDT
*** Bug 965491 has been marked as a duplicate of this bug. ***
Comment 3 Dhiru Kholia 2013-05-21 06:19:30 EDT
*** Bug 965493 has been marked as a duplicate of this bug. ***
Comment 4 Dhiru Kholia 2013-05-21 06:22:56 EDT
Please ignore the duplicate bugs. bugzilla was being super slow (and lazy in committing stuff).
Comment 5 Bruno Wolff III 2013-05-25 12:43:38 EDT
I agree that this must be done. I am testing hardened builds for f19 and f20. If that goes well I'll do this for all current releases.
Comment 6 Fedora Update System 2013-05-25 13:15:41 EDT
maildrop-2.6.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/maildrop-2.6.0-2.fc19
Comment 7 Fedora Update System 2013-05-26 13:01:08 EDT
Package maildrop-2.6.0-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing maildrop-2.6.0-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9301/maildrop-2.6.0-2.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-06-07 23:44:41 EDT
maildrop-2.6.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.