Bug 965489 - SY quickstart camel-jpa-binding warnings
SY quickstart camel-jpa-binding warnings
Status: CLOSED UPSTREAM
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples, SwitchYard (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Fitzpatrick
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 06:01 EDT by ppecka
Modified: 2015-08-02 19:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 15:13:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ppecka 2013-05-21 06:01:00 EDT
Description of problem:
Warnings/Errors found in JBDS "Problems" View, right after quickstart is imported as maven project.

steps to reproduce:
1. Start JBDS
2. import existing maven project
3. Window / Show View / Problems
4. check for errors

Actual results:
No connection specified for project. No database-specific validation will be performed. switchyard-quickstart-camel-jpa-binding         JPA Problem


Expected results:
no warnings in JBDS
Comment 1 Brian Fitzpatrick 2013-08-14 10:53:05 EDT
The issue reported is not with SwitchYard, but with the JPA tooling from Eclipse. The JPA Problem reported is actually just a warning, which can be safely ignored. It's more informational than anything, referring to the fact that there is no Hibernate connection associated with the project.

If you go to the properties for the project (right-click on the project and select Properties), then go to the JPA node in the tree on the left side, you will see that there is no JPA implementation specified, nor is there a Connection specified. Neither is required for the quickstart to run.

So though the label says "problem", since the issue is really just an informational warning I don't think we can do much about it at this point. If you think it shouldn't appear, you can register a bugzilla at Eclipse against the JPA tooling to not show the warning somehow?
Comment 2 Brian Fitzpatrick 2013-09-09 15:13:22 EDT
The problem reported is with the Dali/JPA tooling at Eclipse requiring a database connection in the JPA project metadata. (See the bottom of the page here: http://www.eclipse.org/webtools/dali/docs/3.2/user_guide/tasks011.htm) 

The only way to fix this issue is by adding a database connection, which is unnecessary in this case. 

If you feel that this warning is enough to warrant a change to the Eclipse JPA tooling, please register a bug at Eclipse.

Note You need to log in before you can comment on or make changes to this bug.