Bug 965498 - anaconda text mode user create doesn't take capital characters for username
anaconda text mode user create doesn't take capital characters for username
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-05-21 06:09 EDT by Martin Banas
Modified: 2014-01-30 17:04 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-20.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-30 17:04:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (12.12 KB, text/plain)
2013-05-21 06:09 EDT, Martin Banas
no flags Details
ifcfg.log (486 bytes, text/plain)
2013-05-21 06:09 EDT, Martin Banas
no flags Details
packaging.log (11.44 KB, text/plain)
2013-05-21 06:09 EDT, Martin Banas
no flags Details
program.log (17.17 KB, text/plain)
2013-05-21 06:09 EDT, Martin Banas
no flags Details
storage.log (85.90 KB, text/plain)
2013-05-21 06:10 EDT, Martin Banas
no flags Details
storage.state (20.00 KB, application/octet-stream)
2013-05-21 06:10 EDT, Martin Banas
no flags Details
syslog (66.07 KB, text/plain)
2013-05-21 06:10 EDT, Martin Banas
no flags Details

  None (edit)
Description Martin Banas 2013-05-21 06:09:16 EDT
Description of problem:
If user enters "John" instead of "john" as username, anaconda will not accept it

Version-Release number of selected component (if applicable):
Fedora-19-Beta-RC2
anaconda-19.28
How reproducible:


Steps to Reproduce:
1. Start installation in text mode
2. Proceed to user creation
3. Set username to "John"

Actual results:
anaconda doesn't allow capital letters in username

Expected results:
Anaconda should allow same usernames as useradd.

Additional info:
pyanaconda/ui/tui/spokes/user.py:41:        Entry("Username", "name", re.compile("^[a-z0-9_]+$"), lambda self,args: args._create),
Comment 1 Martin Banas 2013-05-21 06:09:40 EDT
Created attachment 750963 [details]
anaconda.log
Comment 2 Martin Banas 2013-05-21 06:09:45 EDT
Created attachment 750964 [details]
ifcfg.log
Comment 3 Martin Banas 2013-05-21 06:09:50 EDT
Created attachment 750965 [details]
packaging.log
Comment 4 Martin Banas 2013-05-21 06:09:55 EDT
Created attachment 750966 [details]
program.log
Comment 5 Martin Banas 2013-05-21 06:10:00 EDT
Created attachment 750967 [details]
storage.log
Comment 6 Martin Banas 2013-05-21 06:10:05 EDT
Created attachment 750968 [details]
storage.state
Comment 7 Martin Banas 2013-05-21 06:10:11 EDT
Created attachment 750969 [details]
syslog
Comment 8 Marian Ganisin 2013-05-21 06:52:55 EDT
useradd accepts capital letters and creates user John.
Comment 9 tolarewa 2013-05-28 09:37:34 EDT
patch pushed
Comment 10 tolarewa 2013-05-29 11:48:47 EDT
*patch posted to anaconda for review
Comment 11 Adam Williamson 2013-05-29 22:33:38 EDT
posted for review = POST not MODIFIED.
Comment 13 David Shea 2013-08-12 09:16:44 EDT
https://lists.fedorahosted.org/pipermail/anaconda-patches/2013-June/004432.html is the patch that was posted, which wasn't pushed. The patch is fine, but I reset the status to NEW because I've been working on the same thing in the GUI and I plan to tweak the check a little bit. For example, the username should also allow dots and non-initial hyphens.

Note You need to log in before you can comment on or make changes to this bug.