Bug 965510 - gridengine package should be built with PIE flags
gridengine package should be built with PIE flags
Status: CLOSED DUPLICATE of bug 965479
Product: Fedora
Classification: Fedora
Component: gridengine (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 06:14 EDT by Dhiru Kholia
Modified: 2014-03-24 23:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 06:36:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dhiru Kholia 2013-05-21 06:14:52 EDT
Description of problem:

http://fedoraproject.org/wiki/Packaging:Guidelines#PIE says that "you MUST
enable the PIE compiler flags if your package has suid binaries...".

However, currently gridengine is not being built with PIE flags. This is a
clear violation of the packaging guidelines.

This issue (in its wider scope) is being discussed at,

https://fedorahosted.org/fesco/ticket/1104

https://lists.fedoraproject.org/pipermail/devel/2013-March/180827.html

Version-Release number of selected component (if applicable):

gridengine-2011.11p1-11.fc19.x86_64.rpm

How reproducible:

You can use following programs to check if a package is hardened:

http://people.redhat.com/sgrubb/files/rpm-chksec

OR

https://github.com/kholia/checksec

Steps to Reproduce:

Get scanner.py from https://github.com/kholia/checksec

$ ./scanner.py gridengine-2011.11p1-11.fc19.x86_64.rpm
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qalter-ge,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qconf,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qdel-ge,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qevent,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qhost,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qmake-ge,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qmod,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qping,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qquota,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qrdel,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qrstat,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qrsub,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qsh,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qstat-ge,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qsub-ge,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/qtcsh,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/sge_shadowd,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/bin/sgepasswd,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/adminrun,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/authuser,mode=0104755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/checkprog,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/checkuser,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/echo_raw,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/filestat,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/fstype,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/gethostbyaddr,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/gethostbyname,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/gethostname,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/getservbyname,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/infotext,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/loadcheck,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/now,mode=0100755,NX=Enabled,CANARY=Disabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=NA,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/qrsh_starter,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/read_raw,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Disabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/rlogin,mode=0104755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/rsh,mode=0104755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/rshd,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/sge_share_mon,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/spooldefaults,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/spooledit,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/spoolinit,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/testsuidroot,mode=0104755,NX=Enabled,CANARY=Disabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=NA,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/uidgid,mode=0100755,NX=Enabled,CANARY=Disabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=NA,CATEGORY=None
gridengine,gridengine-2011.11p1-11.fc19.x86_64.rpm,/usr/libexec/gridengine/utilbin/valid_jvmlib,mode=0100755,NX=Enabled,CANARY=Disabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=NA,CATEGORY=None
Comment 1 Dhiru Kholia 2013-05-21 06:36:22 EDT

*** This bug has been marked as a duplicate of bug 965479 ***

Note You need to log in before you can comment on or make changes to this bug.