Bug 965549 - heat RDO packages omit default policy.json
heat RDO packages omit default policy.json
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-heat (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHOS Maint
Amit Ugol
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 06:57 EDT by Steven Hardy
Modified: 2014-06-05 05:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 13:08:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Hardy 2013-05-21 06:57:30 EDT
Description of problem:
The heat packages in RDO don't include the /etc/heat/policy.json file, which results in a potentially less secure installation because access to the APIs is not restricted for the in-instance users

Version-Release number of selected component (if applicable):
openstack-heat-2013.1-1.3.fc19.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install heat from RDO repos
2. Note that /etc/heat/policy.json is missing
3. See warning in API logs:
WARNING heat.common.policy [-] Unable to find policy file

Actual results:


Expected results:


Additional info:
Comment 1 Jeff Peeler 2013-05-29 13:08:42 EDT
This has been fixed in RDO, specifically in openstack-heat-common.

Note You need to log in before you can comment on or make changes to this bug.