Bug 965561 - Anaconda in text mode doesn't inform user that new username could not be created.
Anaconda in text mode doesn't inform user that new username could not be crea...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-05-21 07:05 EDT by Martin Banas
Modified: 2014-07-31 05:12 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-21.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-31 05:12:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.85 KB, text/plain)
2013-05-21 07:05 EDT, Martin Banas
no flags Details
ifcfg.log (1.55 KB, text/plain)
2013-05-21 07:05 EDT, Martin Banas
no flags Details
packaging.log (86.21 KB, text/plain)
2013-05-21 07:05 EDT, Martin Banas
no flags Details
program.log (30.27 KB, text/plain)
2013-05-21 07:06 EDT, Martin Banas
no flags Details
screenshot.png (13.89 KB, image/png)
2013-05-21 07:06 EDT, Martin Banas
no flags Details
storage.log (118.42 KB, text/plain)
2013-05-21 07:06 EDT, Martin Banas
no flags Details
storage.state (28.00 KB, application/octet-stream)
2013-05-21 07:06 EDT, Martin Banas
no flags Details
syslog (74.98 KB, text/plain)
2013-05-21 07:06 EDT, Martin Banas
no flags Details

  None (edit)
Description Martin Banas 2013-05-21 07:05:18 EDT
Description of problem:
If username is not created for some reason, anaconda should inform after the installation.

Version-Release number of selected component (if applicable):
Fedora-19-Beta-RC2
anaconda-19.28

How reproducible:
always

Steps to Reproduce:
1. Start installation in text mode
2. create new user, as FULL name enter 'j/ohn', or 'root'
3. Finish installation


Actual results:
Writing network configuration
.
Creating users
.
Configuring addons
.
Running post-installation scripts
.
   Installation complete.   Please return to quit


Expected results:
Anaconda should warn when username wasn't created. The reason should be also mentioned.

Additional info:
Comment 1 Martin Banas 2013-05-21 07:05:43 EDT
Created attachment 751025 [details]
anaconda.log
Comment 2 Martin Banas 2013-05-21 07:05:49 EDT
Created attachment 751026 [details]
ifcfg.log
Comment 3 Martin Banas 2013-05-21 07:05:55 EDT
Created attachment 751027 [details]
packaging.log
Comment 4 Martin Banas 2013-05-21 07:06:00 EDT
Created attachment 751028 [details]
program.log
Comment 5 Martin Banas 2013-05-21 07:06:05 EDT
Created attachment 751029 [details]
screenshot.png
Comment 6 Martin Banas 2013-05-21 07:06:11 EDT
Created attachment 751030 [details]
storage.log
Comment 7 Martin Banas 2013-05-21 07:06:17 EDT
Created attachment 751031 [details]
storage.state
Comment 8 Martin Banas 2013-05-21 07:06:22 EDT
Created attachment 751033 [details]
syslog
Comment 9 Reartes Guillermo 2013-05-26 15:29:06 EDT
I hit it in graphical:

Bug 967245 - CRIT anaconda: Error when creating new user: name contains non-ASCII characters

Mark as DUP if appropriate.
Comment 10 Reartes Guillermo 2013-05-29 14:19:39 EDT
I hit another variant:

Bug 968451 - ERR anaconda: User root already exists, not creating. (reject username 'root' in 'User Creation' screen)
Comment 11 Samantha N. Bueno 2013-12-13 09:17:09 EST
The bugs in comment 9 and comment 10 should be fixed now. Patch posted for original issue in comment 0.
Comment 12 Samantha N. Bueno 2013-12-16 09:55:38 EST
Patch pushed, commit 77233bf78a576b3b0bf94208847cdafd7fadab2d in master.
Comment 13 Samantha N. Bueno 2014-07-31 05:12:47 EDT
Fixed in F21, so closing.

Note You need to log in before you can comment on or make changes to this bug.