Bug 965569 - FTBFS on s390(x)
FTBFS on s390(x)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: alsa-tools (Show other bugs)
19
s390x Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker 967422
  Show dependency treegraph
 
Reported: 2013-05-21 07:23 EDT by Dan Horák
Modified: 2013-05-28 08:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: alsa-tools-1.0.27-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed fix (450 bytes, patch)
2013-05-21 07:23 EDT, Dan Horák
no flags Details | Diff

  None (edit)
Description Dan Horák 2013-05-21 07:23:35 EDT
Created attachment 751039 [details]
proposed fix

Build of alsa-tools fails on s390(x) because the <sys/io.h> header is missing there. In my opinion it'd be better to have a positive list in the #if preprocessor command instead of (wrong) #ifndef __PPC__.


Version-Release number of selected component (if applicable):
alsa-tools-1.0.27-1.fc19
Comment 1 Fedora Update System 2013-05-21 07:27:22 EDT
alsa-tools-1.0.27-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/alsa-tools-1.0.27-2.fc19
Comment 2 Dan Horák 2013-05-21 07:49:20 EDT
relevant part of build.log for the record:

...
configure: creating ./config.status
config.status: creating Makefile
config.status: executing depfiles commands
+ /usr/bin/make -j4
gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"hda-verb\" -DVERSION=\"0.4\" -DSTDC_HEADERS=1 -I.     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m31 -march=z9-109 -mtune=z10 -c hda-verb.c
hda-verb.c:17:20: fatal error: sys/io.h: No such file or directory
 #include <sys/io.h>
                    ^
compilation terminated.
make: *** [hda-verb.o] Error 1
...
Comment 3 Fedora Update System 2013-05-21 13:17:52 EDT
Package alsa-tools-1.0.27-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing alsa-tools-1.0.27-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8742/alsa-tools-1.0.27-2.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-05-24 16:29:23 EDT
alsa-tools-1.0.27-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.