This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 965571 - anaconda.log contains error 'user already exists' even in case the problem was invalid username
anaconda.log contains error 'user already exists' even in case the problem wa...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-05-21 07:24 EDT by Martin Banas
Modified: 2014-01-30 17:05 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-20.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-30 17:05:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (9.85 KB, text/plain)
2013-05-21 07:25 EDT, Martin Banas
no flags Details
ifcfg.log (1.55 KB, text/plain)
2013-05-21 07:25 EDT, Martin Banas
no flags Details
packaging.log (86.21 KB, text/plain)
2013-05-21 07:25 EDT, Martin Banas
no flags Details
program.log (30.27 KB, text/plain)
2013-05-21 07:26 EDT, Martin Banas
no flags Details
storage.log (118.42 KB, text/plain)
2013-05-21 07:26 EDT, Martin Banas
no flags Details
storage.state (28.00 KB, application/octet-stream)
2013-05-21 07:26 EDT, Martin Banas
no flags Details
syslog (74.98 KB, text/plain)
2013-05-21 07:26 EDT, Martin Banas
no flags Details

  None (edit)
Description Martin Banas 2013-05-21 07:24:21 EDT
Description of problem:
If username in text mode is set to invalid (like j/ohn), anaconda reports that there was error creating user because it already exists. It doesn't

Version-Release number of selected component (if applicable):
Fedora-19-Beta-RC2
anaconda-19.28

How reproducible:
always

Steps to Reproduce:
1. Start installation in text mode
2. create new user, as FULL name enter 'j/ohn', or 'root'
3. Finish installation

Actual results:
10:55:45,378 INFO anaconda: Creating users
10:55:45,379 INFO anaconda: created new libuser.conf at /tmp/libuser.5mTk05 with instPath="/mnt/sysimage"
12:55:45,528 CRIT anaconda: Error when creating new user: name contains invalid char `/'
10:55:45,533 ERR anaconda: User j/ohn already exists, not creating.
10:55:45,535 INFO anaconda: Configuring addons

Expected results:
10:55:45,378 INFO anaconda: Creating users
10:55:45,379 INFO anaconda: created new libuser.conf at /tmp/libuser.5mTk05 with instPath="/mnt/sysimage"
12:55:45,528 CRIT anaconda: Error when creating new user: name contains invalid char `/'
10:55:45,535 INFO anaconda: Configuring addons
Comment 1 Martin Banas 2013-05-21 07:25:07 EDT
Created attachment 751043 [details]
anaconda.log
Comment 2 Martin Banas 2013-05-21 07:25:42 EDT
Created attachment 751045 [details]
ifcfg.log
Comment 3 Martin Banas 2013-05-21 07:25:58 EDT
Created attachment 751048 [details]
packaging.log
Comment 4 Martin Banas 2013-05-21 07:26:08 EDT
Created attachment 751049 [details]
program.log
Comment 5 Martin Banas 2013-05-21 07:26:13 EDT
Created attachment 751051 [details]
storage.log
Comment 6 Martin Banas 2013-05-21 07:26:18 EDT
Created attachment 751052 [details]
storage.state
Comment 7 Martin Banas 2013-05-21 07:26:24 EDT
Created attachment 751053 [details]
syslog

Note You need to log in before you can comment on or make changes to this bug.