Bug 965626 - [abrt] evince-3.8.0-2.fc19: magazine_chain_pop_head: Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
[abrt] evince-3.8.0-2.fc19: magazine_chain_pop_head: Process /usr/bin/evince ...
Status: CLOSED DUPLICATE of bug 955362
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
abrt_hash:42c8a7b2cb5e223507b0d24dee1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 08:33 EDT by oliver
Modified: 2013-08-20 04:48 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 04:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (61.73 KB, text/plain)
2013-05-21 08:34 EDT, oliver
no flags Details
File: cgroup (140 bytes, text/plain)
2013-05-21 08:34 EDT, oliver
no flags Details
File: core_backtrace (8.09 KB, text/plain)
2013-05-21 08:34 EDT, oliver
no flags Details
File: dso_list (11.25 KB, text/plain)
2013-05-21 08:34 EDT, oliver
no flags Details
File: environ (3.71 KB, text/plain)
2013-05-21 08:34 EDT, oliver
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-21 08:34 EDT, oliver
no flags Details
File: maps (56.18 KB, text/plain)
2013-05-21 08:34 EDT, oliver
no flags Details
File: open_fds (1.75 KB, text/plain)
2013-05-21 08:34 EDT, oliver
no flags Details
File: proc_pid_status (916 bytes, text/plain)
2013-05-21 08:34 EDT, oliver
no flags Details
File: var_log_messages (4.59 KB, text/plain)
2013-05-21 08:34 EDT, oliver
no flags Details

  None (edit)
Description oliver 2013-05-21 08:33:48 EDT
Description of problem:
This crash appears to be related by fast consecutive pressing of PageUp or PageDown keys.  At least I can trigger random crashes that way, but it's not possible to reproduce the crash deterministically.

Version-Release number of selected component:
evince-3.8.0-2.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        evince schlick-mandziuk-skeel-sinivas1998.pdf
crash_function: magazine_chain_pop_head
executable:     /usr/bin/evince
kernel:         3.9.2-301.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 magazine_chain_pop_head at gslice.c:532
 #1 thread_memory_magazine1_alloc at gslice.c:835
 #2 g_slice_alloc at gslice.c:994
 #3 g_slice_alloc0 at gslice.c:1029
 #4 find_source_list_for_priority at gmain.c:956
 #5 source_add_to_context at gmain.c:992
 #6 g_source_attach_unlocked at gmain.c:1115
 #7 g_source_attach at gmain.c:1162
 #8 g_idle_add_full at gmain.c:5268
 #9 gdk_threads_add_idle_full at gdk.c:877
Comment 1 oliver 2013-05-21 08:34:00 EDT
Created attachment 751099 [details]
File: backtrace
Comment 2 oliver 2013-05-21 08:34:05 EDT
Created attachment 751100 [details]
File: cgroup
Comment 3 oliver 2013-05-21 08:34:11 EDT
Created attachment 751102 [details]
File: core_backtrace
Comment 4 oliver 2013-05-21 08:34:18 EDT
Created attachment 751103 [details]
File: dso_list
Comment 5 oliver 2013-05-21 08:34:24 EDT
Created attachment 751104 [details]
File: environ
Comment 6 oliver 2013-05-21 08:34:29 EDT
Created attachment 751105 [details]
File: limits
Comment 7 oliver 2013-05-21 08:34:41 EDT
Created attachment 751106 [details]
File: maps
Comment 8 oliver 2013-05-21 08:34:46 EDT
Created attachment 751107 [details]
File: open_fds
Comment 9 oliver 2013-05-21 08:34:54 EDT
Created attachment 751109 [details]
File: proc_pid_status
Comment 10 oliver 2013-05-21 08:34:59 EDT
Created attachment 751110 [details]
File: var_log_messages
Comment 11 Andrea Oliveri 2013-06-07 10:16:37 EDT
I read a pdf

reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        evince /home/andrea/Scaricati/9810243316_Chromody.pdf
crash_function: magazine_chain_pop_head
executable:     /usr/bin/evince
kernel:         3.9.4-301.fc19.x86_64
package:        evince-3.8.2-1.fc19
reason:         Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 12 Ondrej Hudlicky 2013-06-20 04:25:16 EDT
Crash happened during scrolling the document in evince
http://team4model.googlecode.com/svn/trunk/resources/paper/Stochastic%20software%20testing.pdf

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        evince '/var/tmp/Stochastic software testing.pdf'
crash_function: magazine_chain_pop_head
executable:     /usr/bin/evince
kernel:         3.9.2-301.fc19.x86_64
package:        evince-3.8.2-1.fc19
reason:         Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 13 Maciek Borzecki 2013-06-21 02:20:44 EDT
I was browsing a presentation that was converted to pdf from ppt. Problem occurred when I started when quickly switching slides

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        evince /home/mborzecki/phd/ekonomia/Makroekonomia-2011/W4-pomiar.pdf
crash_function: magazine_chain_pop_head
executable:     /usr/bin/evince
kernel:         3.9.6-301.fc19.x86_64
package:        evince-3.8.2-1.fc19
reason:         Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:
Comment 14 Faizan Qazi 2013-07-03 20:46:16 EDT
Happened while scrolling through a PDF in Evince.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        evince '/home/faizan/Documents/Classes/NATS 1700/Test 2/What You Need to Know For Test 2.pdf'
crash_function: magazine_chain_pop_head
executable:     /usr/bin/evince
kernel:         3.9.8-300.fc19.x86_64
package:        evince-3.8.2-1.fc19
reason:         Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:
Comment 15 tuxor 2013-07-04 09:23:44 EDT
1. I compile my latex-document with pdflatex (more precisely, using a Makefile).
2. From the terminal, run "evince output.pdf"
3. Close evince with Ctrl+W.

(Please note, that this doesn't seem to be 100% reproducible. It only occurs every 5th to 10th time.)

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        evince /home/thomas/Dokumente/studieren/13ss-bachelorarbeit/quellen/57-SeparatelyConvexFunctions.pdf
crash_function: magazine_chain_pop_head
executable:     /usr/bin/evince
kernel:         3.9.8-300.fc19.x86_64
package:        evince-3.8.2-1.fc19
reason:         Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 16 Sven Oehme 2013-07-09 09:14:07 EDT
just flipped between 2 pages

reporter:       libreport-2.1.5
backtrace_rating: 4
crash_function: magazine_chain_pop_head
executable:     /usr/bin/evince
kernel:         3.9.9-301.fc19.x86_64
package:        evince-3.8.2-1.fc19
reason:         Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            911119
Comment 17 Paul Lazaga 2013-07-11 17:07:37 EDT
While viewing document clicked on thumbnail in left side panel to switch page.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        evince '/home/paul/Documents/SLV Real Estate/Buyers/Patton-Imani, Melanie/Agent_Full4177'
crash_function: magazine_chain_pop_head
executable:     /usr/bin/evince
kernel:         3.9.9-301.fc19.x86_64
package:        evince-3.8.2-1.fc19
reason:         Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:
Comment 18 Praveen Kumar 2013-08-01 07:18:57 EDT
1. Open a pdf file to evince and go to index.
2. when you move forward and backward the contents of index after some time it's hang and crash happen.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        evince /home/prkumar/Documents/think_like_a_programmer.pdf
crash_function: magazine_chain_pop_head
executable:     /usr/bin/evince
kernel:         3.9.5-301.fc19.x86_64
package:        evince-3.8.2-1.fc19
reason:         Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
reported_to:    uReport: BTHASH=17f06fd56e388cc5be8358af437fa5284a8edf61
runlevel:       N 5
uid:            1000
Comment 19 Marek Kašík 2013-08-20 04:48:45 EDT

*** This bug has been marked as a duplicate of bug 955362 ***

Note You need to log in before you can comment on or make changes to this bug.