Bug 965627 - [abrt] system-config-language-1.3.5-19.fc18: packages.py:922:returnHeaderFromPackage:RepoError: Package Header 1:hyphen-gu-0.7.0-2.fc18.noarch: RPM Cannot open
[abrt] system-config-language-1.3.5-19.fc18: packages.py:922:returnHeaderFrom...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
abrt_hash:37ce0cb30488e4704430fad3dd5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 08:42 EDT by rajuramvani
Modified: 2013-11-20 12:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 12:04:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.24 KB, text/plain)
2013-05-21 08:42 EDT, rajuramvani
no flags Details
File: core_backtrace (672 bytes, text/plain)
2013-05-21 08:42 EDT, rajuramvani
no flags Details
File: environ (395 bytes, text/plain)
2013-05-21 08:42 EDT, rajuramvani
no flags Details
File: smolt_data (2.98 KB, application/octet-stream)
2013-05-21 08:42 EDT, rajuramvani
no flags Details

  None (edit)
Description rajuramvani 2013-05-21 08:42:15 EDT
Version-Release number of selected component:
system-config-language-1.3.5-19.fc18

Additional info:
cmdline:        /usr/bin/python /usr/share/system-config-language/system-config-language.py
dso_list:       yum-3.4.3-54.fc18.noarch
executable:     /usr/share/system-config-language/system-config-language.py
kernel:         3.8.11-200.fc18.x86_64
uid:            0
ureports_counter: 1

Truncated backtrace:
packages.py:922:returnHeaderFromPackage:RepoError: Package Header 1:hyphen-gu-0.7.0-2.fc18.noarch: RPM Cannot open

Traceback (most recent call last):
  File "/usr/share/system-config-language/language_gui.py", line 179, in okClicked
    self.apply()
  File "/usr/share/system-config-language/language_gui.py", line 298, in apply
    install.install_language (self.mainWindow, grpid)
  File "/usr/share/system-config-language/gui_install.py", line 456, in install_language
    self.runTransaction(mainWindow)
  File "/usr/share/system-config-language/gui_install.py", line 399, in runTransaction
    self.populateTs(keepold=0)
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 275, in populateTs
    hdr = txmbr.po.returnHeaderFromPackage()
  File "/usr/lib/python2.7/site-packages/yum/packages.py", line 922, in returnHeaderFromPackage
    raise Errors.RepoError, 'Package Header %s: RPM Cannot open' % self
RepoError: Package Header 1:hyphen-gu-0.7.0-2.fc18.noarch: RPM Cannot open

Local variables in innermost frame:
self: <YumAvailablePackageSqlite : 1:hyphen-gu-0.7.0-2.fc18.noarch (0x61766d0)>
ts: <rpmUtils.transaction.TransactionWrapper instance at 0x33ab488>
rpmfile: '/var/cache/yum/x86_64/18/fedora/packages/hyphen-gu-0.7.0-2.fc18.noarch.rpm'
Comment 1 rajuramvani 2013-05-21 08:42:20 EDT
Created attachment 751118 [details]
File: backtrace
Comment 2 rajuramvani 2013-05-21 08:42:24 EDT
Created attachment 751119 [details]
File: core_backtrace
Comment 3 rajuramvani 2013-05-21 08:42:30 EDT
Created attachment 751120 [details]
File: environ
Comment 4 rajuramvani 2013-05-21 08:42:35 EDT
Created attachment 751121 [details]
File: smolt_data
Comment 5 Parag Nemade 2013-05-21 23:21:44 EDT
I can see this looks a repository problem. Try as a root "yum clean all" and then try the same steps that caused above error.

Note You need to log in before you can comment on or make changes to this bug.