Bug 965636 - streaming with no backing file should not do anything
streaming with no backing file should not do anything
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Max Reitz
Virtualization Bugs
:
Depends On: 808114
Blocks: 806280 1080820
  Show dependency treegraph
 
Reported: 2013-05-21 08:59 EDT by Paolo Bonzini
Modified: 2014-06-23 02:10 EDT (History)
10 users (show)

See Also:
Fixed In Version: qemu-kvm-1.5.3-34.el7
Doc Type: Bug Fix
Doc Text:
Previously, streaming an image without a backing file would waste time copying the whole image onto itself. Now, if you attempt to stream an image that does not have a backup file, the streaming job ends immediately.
Story Points: ---
Clone Of: 808114
Environment:
Last Closed: 2014-06-13 08:04:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2013-05-21 08:59:16 EDT
+++ This bug was initially created as a clone of Bug #808114 +++

Description of problem:
Streaming an image with no backing file wastes time copying the whole image onto itself.

Version-Release number of selected component (if applicable):
qemu-kvm 267rhev

How reproducible:
100%

Steps to Reproduce:
1. install to qcow2
2. start QEMU
3. do block_stream virtio0
  
Actual results:
Streaming job runs

Expected results:
Streaming job ends immediately

Additional info:
Also related, streaming should not even start if the image format does not support bdrv_change_backing_file.

--- Additional comment from juzhang on 2012-03-30 23:05:27 EDT ---

Can reproduce with qemu-kvm-267.el6ev.

1.boot guest with qcow2
2.block_stream virtio0
3.info block-jobs

Resutls
(qemu) info block-jobs 
Streaming device virtio0: Completed 12817137664 of 21474836480 bytes, speed limit 0 bytes/s

--- Additional comment from Ademar de Souza Reis Jr. on 2012-09-26 20:48:35 EDT ---

Deferring to 6.5 due to capacity. If a customer reports it, we'll consider it of higher priority. Nevertheless, if a patch is available it's for sure welcome in 6.4.

--- Additional comment from Ludek Smid on 2013-03-07 09:38:57 EST ---

Since the release flag was set to ? after the qa_ack and pm_ack flags were set to + (was likely set for the previous release), the qa_ack and pm_ack flags have been reset to ? by the bugbot (pm-rhel). This action ensures the proper review by Product Management.
Comment 2 Miroslav Rezanina 2014-01-08 07:43:38 EST
Fix included in qemu-kvm-1.5.3-34.el7
Comment 4 Shaolong Hu 2014-01-24 00:22:42 EST
Verified on qemu-kvm-rhev-1.5.3-39.el7.x86_64:


after issue block stream, job complete immediately, log shows in QMP connection:

{"timestamp": {"seconds": 1390540852, "microseconds": 646379}, "event": "BLOCK_JOB_COMPLETED", "data": {"device": "drive-virtio-disk0", "len": 0, "offset": 0, "speed": 0, "type": "stream"}}
Comment 6 Ludek Smid 2014-06-13 08:04:24 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.