Bug 965646 - [abrt] libreoffice-core-3.6.6.2-5.fc18: get: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.6.6.2-5.fc18: get: Process /usr/lib64/libreoffice/p...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:05a0d215240f90ab8792ea60a24...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 09:06 EDT by Marcela Mašláňová
Modified: 2013-07-11 14:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 14:37:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (57.96 KB, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details
File: cgroup (128 bytes, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details
File: core_backtrace (9.73 KB, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details
File: dso_list (20.87 KB, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details
File: environ (2.25 KB, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details
File: maps (95.09 KB, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details
File: open_fds (1.30 KB, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details
File: proc_pid_status (941 bytes, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details
File: var_log_messages (1.02 KB, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details
File: xsession_errors (3.26 KB, text/plain)
2013-05-21 09:06 EDT, Marcela Mašláňová
no flags Details

  None (edit)
Description Marcela Mašláňová 2013-05-21 09:06:13 EDT
Description of problem:
Copying few slides from one presentation to another was successful, but then impress crashed.

Version-Release number of selected component:
libreoffice-core-3.6.6.2-5.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress /home/marca/Documents/prednaska/summit/mmaslano_T_0900_bring_order_into_your_packaging_madness_with_software_collections.odp --splash-pipe=6
crash_function: get
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.8.9-200.fc18.x86_64
runlevel:       N 5
uid:            8270
ureports_counter: 1

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 get at /usr/src/debug/libreoffice-3.6.6.2/solver/unxlngx6.pro/inc/rtl/ref.hxx:164
 #1 SfxViewShell::GetController at /usr/src/debug/libreoffice-3.6.6.2/sfx2/source/view/viewsh.cxx:1950
 #2 sd::framework::FrameworkHelper::FrameworkHelper at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/framework/tools/FrameworkHelper.cxx:405
 #3 sd::framework::FrameworkHelper::Instance at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/framework/tools/FrameworkHelper.cxx:358
 #4 sd::ViewShellBase::GetMainViewShell at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/view/ViewShellBase.cxx:414
 #5 sd::slidesorter::view::SlideSorterView::SetState at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/slidesorter/view/SlideSorterView.cxx:1032
 #6 sd::slidesorter::view::SlideSorterView::SetPageUnderMouse at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/slidesorter/view/SlideSorterView.cxx:997
 #7 sd::slidesorter::view::SlideSorterView::UpdatePageUnderMouse at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/slidesorter/view/SlideSorterView.cxx:959
 #10 sd::slidesorter::view::SlideSorterView::Rearrange at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/slidesorter/view/SlideSorterView.cxx:398
 #11 sd::slidesorter::view::SlideSorterView::RequestRearrange at /usr/src/debug/libreoffice-3.6.6.2/sd/source/ui/slidesorter/view/SlideSorterView.cxx:368

Potential duplicate: bug 817829
Comment 1 Marcela Mašláňová 2013-05-21 09:06:18 EDT
Created attachment 751142 [details]
File: backtrace
Comment 2 Marcela Mašláňová 2013-05-21 09:06:23 EDT
Created attachment 751144 [details]
File: cgroup
Comment 3 Marcela Mašláňová 2013-05-21 09:06:27 EDT
Created attachment 751145 [details]
File: core_backtrace
Comment 4 Marcela Mašláňová 2013-05-21 09:06:32 EDT
Created attachment 751147 [details]
File: dso_list
Comment 5 Marcela Mašláňová 2013-05-21 09:06:35 EDT
Created attachment 751149 [details]
File: environ
Comment 6 Marcela Mašláňová 2013-05-21 09:06:39 EDT
Created attachment 751151 [details]
File: limits
Comment 7 Marcela Mašláňová 2013-05-21 09:06:43 EDT
Created attachment 751153 [details]
File: maps
Comment 8 Marcela Mašláňová 2013-05-21 09:06:47 EDT
Created attachment 751155 [details]
File: open_fds
Comment 9 Marcela Mašláňová 2013-05-21 09:06:51 EDT
Created attachment 751157 [details]
File: proc_pid_status
Comment 10 Marcela Mašláňová 2013-05-21 09:06:54 EDT
Created attachment 751158 [details]
File: var_log_messages
Comment 11 Marcela Mašláňová 2013-05-21 09:06:58 EDT
Created attachment 751159 [details]
File: xsession_errors
Comment 12 Michael Stahl 2013-07-11 14:37:35 EDT
have committed something upstream that could perhaps make it not crash.

master a9e0c222f504104124485ef4684ce6f79d3dee52
libreoffice-4-1 d9b36d3623ce5d88bfaca7a31426fa126a6ce4ac

because i'm not really sure if it actually fixes things i'll not add the patch to Fedora packages; it'll get into Fedora 19 with the 4.1.1 upgrade.

Note You need to log in before you can comment on or make changes to this bug.