Bug 965774 - backspace in text mode kills the entire prompt
backspace in text mode kills the entire prompt
Status: CLOSED DUPLICATE of bug 965430
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
low Severity low
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 13:04 EDT by Jeff Bastian
Modified: 2013-06-03 10:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 10:39:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2013-05-21 13:04:57 EDT
Description of problem:
If installing Fedora 19 in text mode, hitting the backspace will delete the entire text of the prompt.

For example, if the screen shows:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 1) [!] Timezone settings          2) [!] Install Destination
        (Timezone is not set.)            (No disks selected)
 3) [!] Set root password          4) [!] Create user
        (Password is not set.)            (No user will be created)
  Please make your choice from above ['q' to quit | 'c' to continue]:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

And you type '5' and then realize your mistake and hit backspace, you get:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 1) [!] Timezone settings          2) [!] Install Destination
        (Timezone is not set.)            (No disks selected)
 3) [!] Set root password          4) [!] Create user
        (Password is not set.)            (No user will be created)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~



Version-Release number of selected component (if applicable):
anaconda-19.28-1    (Fedora 19 Beta RC2)

How reproducible:
every time

Steps to Reproduce:
1. install in text mode
2. hit backspace at a prompt

Actual results:
prompt disappears

Expected results:
only the text you typed is erased

Additional info:
Comment 1 Samantha N. Bueno 2013-06-03 10:39:00 EDT

*** This bug has been marked as a duplicate of bug 965430 ***

Note You need to log in before you can comment on or make changes to this bug.