Bug 965784 - Logging out from Foreman does not take user to signo login page
Logging out from Foreman does not take user to signo login page
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Og Maciel
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2013-05-21 13:42 EDT by Og Maciel
Modified: 2014-01-27 08:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-18 17:23:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2013-05-21 13:42:42 EDT
Description of problem:

Logging out from Foreman does not take user to signo login page. Instead you get a "generic" /foreman/user/login page.

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.7-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.7-1.el6_4.noarch
* candlepin-tomcat6-0.8.7-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-29.noarch
* foreman-postgresql-1.1.10002-29.noarch
* katello-1.4.2-6.el6sat.noarch
* katello-all-1.4.2-6.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-5.el6sat.noarch
* katello-cli-common-1.4.2-5.el6sat.noarch
* katello-common-1.4.2-6.el6sat.noarch
* katello-configure-1.4.3-9.el6sat.noarch
* katello-configure-foreman-1.4.3-9.el6sat.noarch
* katello-foreman-all-1.4.2-6.el6sat.noarch
* katello-glue-candlepin-1.4.2-6.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-6.el6sat.noarch
* katello-glue-pulp-1.4.2-6.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* openldap-devel-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.10-1.el6sat.noarch
* signo-katello-0.0.10-1.el6sat.noarch

How reproducible:

Steps to Reproduce:
1. Login to Foreman and then log out
2. Try to login immediately back to foreman using the provided login form

Actual results:

Since you're not taken to the signo login page, you cannot login

Expected results:

Additional info:
Comment 1 Marek Hulan 2013-06-05 03:07:11 EDT
It works for me. The only case this could happen intentionally is when you login into foreman without Signo at first. It means when you enter foreman from /foreman/users/login and then sign out. The old way (/foreman/users/login) is used as fallback when Signo is not running or has some problems so this may cause some confusion. You can search for "SSO failed, falling back to login form" in foreman production.log. Maybe we could display some notice to user when fallback is activated, but I wanted it to be transparent.
Comment 2 Marek Hulan 2013-06-11 07:13:04 EDT
Is it still present? Could you please provide more reproducing info? Also foreman log could be useful.
Comment 3 Og Maciel 2013-06-11 10:47:12 EDT
Comment 4 Mike McCune 2013-07-18 17:23:39 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.