Bug 965787 - openstack-packstack: Installation failed on iptables Command Error 'Resource temporarily unavailable'.
openstack-packstack: Installation failed on iptables Command Error 'Resource ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: snapshot2
: 3.0
Assigned To: Martin Magr
Nir Magnezi
: TestBlocker, Triaged
Depends On: 908695
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 13:45 EDT by Jaroslav Henner
Modified: 2016-04-27 01:23 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.8.dev601
Doc Type: Bug Fix
Doc Text:
Previously a race condition existed when deploying compute nodes whereby the order in which libvirt and PackStack itself modified the firewall rules was unpredictable. As a result the iptables firewall rules generated by the deployment would sometimes be incorrect, resulting in connectivity issues. PackStack has been updated to prevent this race condition from occurring and ensure the correct iptables firewall rules are deployed.
Story Points: ---
Clone Of: 908695
Environment:
Last Closed: 2013-06-11 14:51:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 22421 None None None Never
OpenStack gerrit 31486 None None None Never

  None (edit)
Comment 1 Jaroslav Henner 2013-05-21 13:47:42 EDT
This problem occurs rarely, maybe 5% of deployments. Probably only when one is deploying a compute node on separate servers.
Comment 5 Martin Magr 2013-06-05 07:58:49 EDT
The problem was in case you had separate compute nodes in your setup. The race condition for firewall wasn't appended to manifestfor them.

So I suggest running setup with 1 controller node and 1+ compute nodes. You can also check in /var/tmp/packstack/<YYMMDD-hhmmss>-<random>/manifests/<compute_host_ip>_nova.pp.log that firewall rule '001 nova compute incoming' is applied before class 'nova::compute::libvirt' (or more precisely before service 'libvirt').
Comment 6 Nir Magnezi 2013-06-05 09:31:17 EDT
(In reply to Martin Magr from comment #5)
> The problem was in case you had separate compute nodes in your setup. The
> race condition for firewall wasn't appended to manifestfor them.
> 
> So I suggest running setup with 1 controller node and 1+ compute nodes. You
> can also check in
> /var/tmp/packstack/<YYMMDD-hhmmss>-<random>/manifests/<compute_host_ip>_nova.
> pp.log that firewall rule '001 nova compute incoming' is applied before
> class 'nova::compute::libvirt' (or more precisely before service 'libvirt').

Thank you!
Comment 7 Nir Magnezi 2013-06-05 09:34:23 EDT
Verified NVR: openstack-packstack-2013.1.1-0.8.dev601.el6ost.noarch

Installed Openstack via packstack with 1 controller and 2 compute nodes.
No errors were indicated in stdout nor in packstack logs.
Comment 8 errata-xmlrpc 2013-06-11 14:51:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0938.html

Note You need to log in before you can comment on or make changes to this bug.