This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 965795 - postfix selinux errors
postfix selinux errors
Status: CLOSED DUPLICATE of bug 964679
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 14:15 EDT by Samuel Sieb
Modified: 2013-05-22 02:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 02:30:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samuel Sieb 2013-05-21 14:15:18 EDT
Getting selinux errors from postfix.

setroubleshoot: SELinux is preventing /usr/libexec/postfix/cleanup from 'read, write' accesses on the file /var/spool/postfix/pid/unix.cleanup.

I tried restorecon and restarting the service.  It didn't fix it.  I deleted the file, now I'm getting:

setroubleshoot: SELinux is preventing /usr/libexec/postfix/cleanup from create access on the file unix.cleanup.

Details:

SELinux is preventing /usr/libexec/postfix/cleanup from create access on the file unix.cleanup.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that cleanup should be allowed create access on the unix.cleanup file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep cleanup /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp


Additional Information:
Source Context                system_u:system_r:postfix_cleanup_t:s0
Target Context                system_u:object_r:postfix_var_run_t:s0
Target Objects                unix.cleanup [ file ]
Source                        cleanup
Source Path                   /usr/libexec/postfix/cleanup
Port                          <Unknown>
Host                          worklap
Source RPM Packages           postfix-2.9.6-4.fc18.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-95.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     worklap
Platform                      Linux worklap 3.9.2-200.fc18.i686.PAE #1 SMP Mon
                              May 13 14:38:57 UTC 2013 i686 i686
Alert Count                   4
First Seen                    2013-05-21 11:08:53 PDT
Last Seen                     2013-05-21 11:11:56 PDT
Local ID                      9a44282a-1457-4fe0-a1c4-71ca42cb2485

Raw Audit Messages
type=AVC msg=audit(1369159916.342:4732): avc:  denied  { create } for  pid=10150 comm="cleanup" name="unix.cleanup" scontext=system_u:system_r:postfix_cleanup_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=SYSCALL msg=audit(1369159916.342:4732): arch=i386 syscall=open success=no exit=EACCES a0=b8e03148 a1=80c2 a2=180 a3=b8e03148 items=0 ppid=10066 pid=10150 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=cleanup exe=/usr/libexec/postfix/cleanup subj=system_u:system_r:postfix_cleanup_t:s0 key=(null)

Hash: cleanup,postfix_cleanup_t,postfix_var_run_t,file,create
Comment 1 Miroslav Grepl 2013-05-22 02:30:03 EDT

*** This bug has been marked as a duplicate of bug 964679 ***

Note You need to log in before you can comment on or make changes to this bug.