Bug 965796 - Focus problem after hiding terminal in XFCE
Focus problem after hiding terminal in XFCE
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: guake (Show other bugs)
18
All Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1171547
  Show dependency treegraph
 
Reported: 2013-05-21 14:17 EDT by Cliff
Modified: 2014-12-07 23:08 EST (History)
4 users (show)

See Also:
Fixed In Version: guake-0.4.4-11.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1171547 (view as bug list)
Environment:
Last Closed: 2013-10-05 21:35:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cliff 2013-05-21 14:17:40 EDT
Description of problem:

This bug affects XFCE and maybe other DEs, but not Gnome.
When hiding the terminal with the hotkey, the window that had focus before opening the terminal doesn't regain focus.


Version-Release number of selected component (if applicable):

0.4.4-9, but going all the way back to F17.


How reproducible:

Everytime


Steps to Reproduce:
1. Open any window in XFCE so it has focus.
2. Open guake by hitting F12
3. Close guake by hitting F12


Actual results:

The window that had focus before opening guake doesn't have it, the desktop has focus instead.


Expected results:

The window should have focus.


Additional info:

This wrong behaviour is caused by a patch introduced to fix this bug:
http://guake.org/ticket/436
But this was a hack to work around a gnome 3.4 bug, which is fixed now and isn't necessary anymore. Changing the lines

self.window.set_keep_below(True)
self.window.hide() # Don't use hide_all here!

back to

self.window.hide() # Don't use hide_all here!

doesn't change any gnome behaviour but fixes the problem in XFCE.
(This hack isn't even present in the upstream code.)

I hope that explains it well enough.
Comment 1 Aiman 2013-06-27 09:03:16 EDT
As above, I am experiencing the same issue on Xfce. When hiding the Guake window, focus is in limbo. It does not return to the previous focused window or any window at all. I have to manually click on a window for it to receive focus.

I initially thought the problem was the Gnome 3.4 bug. So when I went to check /usr/bin/guake I found part of the patch already there. So then I thought maybe the patch itself is the problem:

http://pkgs.fedoraproject.org/cgit/guake.git/commit/?id=af1c2f75195f4c9e5618693babce8c4c42d58607

I changed /usr/bin/guake to revert the patch and my focus issues are now solved.

Is this patch still necessary?
Comment 2 Peter Hatina 2013-07-16 17:16:28 EDT
I can confirm, that reverting the patch makes Guake work properly under Xfce (F19).
Comment 3 Aiman 2013-09-09 14:12:24 EDT
This issue is still present in Fedora 19.
Comment 4 Pierre-YvesChibon 2013-09-30 06:15:48 EDT
I no longer have the problem on F19 w/o this patch, reverting it.
Comment 5 Fedora Update System 2013-09-30 07:25:45 EDT
guake-0.4.4-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/guake-0.4.4-11.fc19
Comment 6 Fedora Update System 2013-09-30 07:25:56 EDT
guake-0.4.4-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/guake-0.4.4-11.fc20
Comment 7 Fedora Update System 2013-09-30 21:59:15 EDT
Package guake-0.4.4-11.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing guake-0.4.4-11.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17980/guake-0.4.4-11.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-10-05 21:35:20 EDT
guake-0.4.4-11.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-11-23 22:49:45 EST
guake-0.4.4-11.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.