Bug 965842 - network device configuration named 'Boot Disk'
network device configuration named 'Boot Disk'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 16:25 EDT by Bill Nottingham
Modified: 2014-03-16 23:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: dracut-027-81.git20130531.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-01 23:01:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2013-05-21 16:25:06 EDT
Description of problem:

Did a virt install over HTTP. My ifcfg-eth0 contains:

NAME="Boot Disk"

Even if the install was done via downloading kernel/boot images over network, that seems an odd name.

Version-Release number of selected component (if applicable):

20130521 nightly

How reproducible:

once so far

Steps to Reproduce:
1. Install with virt-manager
2. Look at ifcfg-eth0
Comment 1 Brian Lane 2013-05-21 20:38:31 EDT
Please attach the logs as individual text/plain files.
Comment 2 Radek Vykydal 2013-05-22 07:01:14 EDT
The name is set by dracut generating the ifcfg file.

Just for information, in anaconda we use device name as NAME of a connection when dumping ifcfg files for connections created automatically by NM, eg we rename "Wired Connection 1" to "eth0" so that the dumped file is named ifcfg-eth0 instead of ifcfg-Wired_Connection_1).
Comment 3 Bill Nottingham 2013-05-22 14:03:51 EDT
So this is a dracut bug? I note that if I have multiple adapters, they all get 'Boot Disk' set for NAME.
Comment 4 Harald Hoyer 2013-05-28 10:54:10 EDT
Oh :) that name was copied and pasted since at least 4 years (git blame for the rescue :) ... 
apparently nobody has used the ifcfg-* files since then :)
Comment 5 Harald Hoyer 2013-05-28 10:57:22 EDT
commit 284d62da816a9d3678906e9dbeb796132016b9c9
Comment 6 Fedora Update System 2013-05-31 04:23:14 EDT
dracut-027-81.git20130531.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dracut-027-81.git20130531.fc19
Comment 7 Fedora Update System 2013-05-31 14:08:50 EDT
Package dracut-027-81.git20130531.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-027-81.git20130531.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9728/dracut-027-81.git20130531.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-06-01 23:01:07 EDT
dracut-027-81.git20130531.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.