This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 965896 - Proposal: suppress screensaver during install from live images
Proposal: suppress screensaver during install from live images
Status: CLOSED DUPLICATE of bug 928825
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All All
unspecified Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 19:09 EDT by Adam Williamson
Modified: 2014-03-18 10:22 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 10:22:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-05-21 19:09:55 EDT
A couple of different people recently have mentioned to me the fact that the live installer does not suppress the screensaver from kicking in, so if you run a live install, the screensaver (shield, in GNOME) usually kicks in during the installation process.

It would be quite trivial for us to suppress the screensaver (actually, suppress the session idle timeout) while anaconda was running, if we wanted to. The GTK_APPLICATION_INHIBIT_IDLE flag for gtk_application_inhibit does this:

https://developer.gnome.org/gtk3/3.3/GtkApplication.html#GtkApplicationInhibitFlags

There's an example in the totem source, src/plugins/screensaver/totem-screensaver.c , function "totem_screensaver_update_from_state", if you want one.

So, this bug is just to propose that. Up to you folks if you think it's desirable or not; like I said, a couple of people have suggested that it would make sense (and be consistent with the non-live installer, where there is no screensaver).
Comment 1 Steve Tyler 2013-07-13 15:05:35 EDT
The screensaver turns the display black.

That is not something a user wants to have happen during an install, since it looks like the installer crashed if the user was away from the computer when the display faded to black.

Further, if the user presses a key, a huge clock is displayed with no indication as to what the user should do next ...

+1 to disable screensaver during live installs.

Confirmed with Fedora-Live-Desktop-i686-19-1.iso.
Comment 2 Adam Williamson 2013-07-17 15:13:12 EDT
FWIW, I talked to the desktop team about just suppressing the 'shield' entirely during live sessions, and got this:

12-07-2013 13:27:33 > adamw: mclasen: i'm firing a question and running away, sorry, but: do you know if there's a reason we don't suppress the screen lock on the desktop live?
12-07-2013 13:27:38 > adamw: apparently we do on all the other lives, just not deskto[
12-07-2013 13:27:45 > adamw: will pick up the answer in an hour or so
12-07-2013 13:27:54 < mclasen!~mclasen@pool-71-174-250-64.bstnma.fios.verizon.net: I thought we did
12-07-2013 13:28:13 < mclasen!~mclasen@pool-71-174-250-64.bstnma.fios.verizon.net: if you mean the screen shield, that will come done if the session goes idle
12-07-2013 13:28:25 < hadess!~hadess@mon69-7-83-155-44-161.fbx.proxad.net: adamw, what mclasen said
12-07-2013 13:28:32 < mclasen!~mclasen@pool-71-174-250-64.bstnma.fios.verizon.net: but you wouldn't get asked a password - since the live user doesn't have one
12-07-2013 13:28:37 < hadess!~hadess@mon69-7-83-155-44-161.fbx.proxad.net: adamw, if it doesn't ask for a password, it's the screen shield
12-07-2013 14:57:25 > adamw: hadess: well, that's what i meant. i think of them as pretty much the same thing. just obviously no password entry for a user with no password.
12-07-2013 14:58:45 < hadess!~hadess@mon69-7-83-155-44-161.fbx.proxad.net: adamw, and also when it doesn't lock :)
12-07-2013 14:58:52 < hadess!~hadess@mon69-7-83-155-44-161.fbx.proxad.net: no, it cannot be turned off
12-07-2013 14:59:01 > adamw: why not?
12-07-2013 15:53:03 < hadess!~hadess@mon69-7-83-155-44-161.fbx.proxad.net: because there's a screen shield when the screen turns off
12-07-2013 15:53:39 < hadess!~hadess@mon69-7-83-155-44-161.fbx.proxad.net: (avoids unfortunate clicks and touches)
12-07-2013 18:08:59 < mclasen!~mclasen@pool-71-174-250-64.bstnma.fios.verizon.net: adamw: if you don't like it, you can inhibit the session from going idle
12-07-2013 18:09:11 < mclasen!~mclasen@pool-71-174-250-64.bstnma.fios.verizon.net: but I think that would be a pretty pointless difference to normal behaviour
12-07-2013 18:09:28 < mclasen!~mclasen@pool-71-174-250-64.bstnma.fios.verizon.net: disabling the lock screen was really always about the password
12-07-2013 18:43:56 < airlied_!airlied@fruit.freedesktop.org: mclasen: unless you actually want to look at something on the screen :-P
12-07-2013 18:44:32 < mclasen!~mclasen@pool-71-174-250-64.bstnma.fios.verizon.net: airlied_: then you would not be idle, I guess
12-07-2013 18:48:58 < airlied_!airlied@fruit.freedesktop.org: it just sucks when using two computers and being too lazy to get synergy working
12-07-2013 18:51:44 < airlied_!airlied@fruit.freedesktop.org: though inhibiting idle got a bit harder since gnome-screensaver-command lost the command line options
12-07-2013 18:51:50 < airlied_!airlied@fruit.freedesktop.org: now I believe its some dbus incantation
12-07-2013 18:55:57 < mclasen!~mclasen@pool-71-174-250-64.bstnma.fios.verizon.net: gnome-session-inhibit --inhibit idle --inhibit-only  should do it nowadays

It was a bit of a disjointed discussion, and I may not have actually made it entirely clear why we might want to do this in the first place.
Comment 3 Matthias Clasen 2013-07-17 15:42:15 EDT
I'm 100% sure we've had this discussion before in bugzilla. The right thing to do if you want to treat the installer as something that should not disappear behind the screen shield, is to make anaconda inhibit the session from going idle while it is doing its thing.

That is a very easy dbus call to make, and we even provide a commandline tool to do the same.
Comment 4 Adam Williamson 2013-07-17 15:51:56 EDT
Well yeah, that's what I proposed in this bug in the first place. But the response from anaconda was 'why do we have the idle shield in the live session at all? Can't we just turn it off?'
Comment 5 Matthias Clasen 2013-07-17 17:04:25 EDT
Ok, let me give a clear answer then: No
Comment 6 Chris Lumens 2013-08-21 17:19:20 EDT
I even have some code to do this somewhere.
Comment 7 Chris Lumens 2014-03-18 10:22:20 EDT

*** This bug has been marked as a duplicate of bug 928825 ***

Note You need to log in before you can comment on or make changes to this bug.